SV-328 & Qik 2s9v1 Engine not running issue


I’m building a 4 engine robot with 50:1 and 2.5:1 gear ratios. The two 50:1 motors are successfully powered by the Orangutan SV-328 controller and the two 2.5:1 are supposed to be controlled by the Qik 2s9v1. The SV_328 and Qik are connected by short cables Rx->Tx and vice versa. Qik logic power is connected to unused +5V GND connectors on the SV-328 8 ports I/O field.

I’ve managed to verify that the serial connection between the SV-328 and the Qik is working properly by sending 0xBF => 0x82 and receiveing 0x40. The heartbeat is “up and running” and there is no error (the red LED is turend off and the GetLastError serial command returns 0x00). (@highest available baudrate)

Whilst troubleshooting I’m only trying to connect one DC engine (M0) to the Qik, but I do not get anything at all from the Qik. If I connect the 2.5:1 engine directly to the batteries (10 cell NIMH @ 2800mAH that can handle 16A) everything is working as it should (except from the fact that I cannot control it). I’ve tried a few different PWM frequencies with the same result (I don’t even hear a humming sound or see the slightest movement from the engine.)

Additional components on the robot are, one small servo and one (sweeping) sonar.

I have no capacitors soldered to the engines (just yet anyway), and the engine cabling are not twisted. (Speaker cables) But I cannot see that this should be of such importance for an early prototype. I’ve haven’t soldered the jumper connections to the Qik as I do not want them there in the final solution, hence no possibility to test the demo mode. In a worse case scenario I can solder the jumper connectors onto the Qik, but as a last resort.

I’ve measuered all the voltages at the Qik (Vmot/GND & VCC/GND and they are 12.X V and 4.8V respectively).

The code is written in Ateml Studio 6 (or actually 4.X, but converted to Atmel Studio 6), but I’m fairly sure the code is not the source of the issue. (no pun intended).
Code snippet for driving M0 forward.

char sendBuf[2];
sendBuf[0] = 0x88;
sendBuf[1] = 0x7F;
serial_send(sendBuf, 2);

I’ve also tried adding various delays after sending the serial commands, but with no luck.

Any advice would be greatly apprechiated!

BR David

okay, a follow-up. It struck me that the stall current for the above mentioned engines are a tad too high (4.6A), so I just had to try with a smaller engine, with a stall current @ 1.3A, but still no change…

Right, even tried with a jumper between A and B and still nothing, even with the smaller engine… the LEDs were blinking as they should…

Ideas anyone??

BR David


Can you try simplifying your system? If you connect just the qik to the motor and use the demo mode, you should be able to learn a lot about what is causing the problem.

- Ryan

Is it necessary to connect both Vmot and Vcc in the previously mentioned setup? Will try this tonight!

did another test the other night, tried to power the motor in parallell with a 50:1 motor on the SV-328, which worked fine, though spinning a tad slow.

Yes, you need to connect VMOT and VCC. The qik user’s guide has lots of information about this.

I missed your note that you wanted to avoid soldering the headers into the jumper connections used for demo mode. You can just connect a shorting block to a 1x2 male header and hold it in place with your hand.

- Ryan