Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Stepper driver and motor not working with Arduino

Hi there, I’m trying to get a 36v4 Driver to work with the SOYO SY42STH38-1684A (NEMA17) and an Arduino Uno. I know there have been several forum posts about this very problem before, but I’ve read them carefully and haven’t found any clues about why this isn’t working. Sorry if I’m missing something obvious.

Here is a photo of my setup. I’ve tried to follow the wiring as in the GitHub repo and this forum post as closely as possible.

I don’t have an oscilloscope (yet, it’s on the way), but with a multimeter I was able to verify:

  1. I get my input voltage across GND/VM, so I feel confident that the board is receiving power and that I haven’t supplied reverse voltage. I’ve tried 10-20v from my DC bench power supply.

  2. I measure ~5v between GND/IOREF and between GND/SLEEP, so these appear to be connected correctly.

On the other hand, these measurements were not as expected. Should these concern me?

  1. I can’t detect any voltage on the V5 (OUT) pin.

  2. I can’t detect any connection between GND on the microcontroller side and GND on the power supply side. The voltages I reported above only work if I connect to the GND on the same side of the board.

I tried both examples in the HighPowerStepperDriver package. Neither of them is doing anything.

Any idea what I am doing wrong?

Hello.

It looks like your male header is not soldered on correctly for use with a breadboard. It probably will not pug in far enough to make good connections. Can you remove the driver from the breadboard and post some closer pictures of all your soldered connections? Can power the driver and repeat your measurements of 5V (OUT) and GND while you have the driver removed from the breadboard too?

By the way, I think the rest of your connections look okay, but most of the wires being the same color and all the excess wire made your connections difficult to follow.

- Patrick

Good catch, my lack of soldering was indeed the problem! I had hoped I would get contact there even without soldering, but I was wrong about that. Once I soldered all the pins, it started to work as expected.

2 Likes