Mini Maestro and VSA software functionality


I am new to this so forgive my lack of knowledge. I did read the “getting help” post and everything I could find on these two products but am unclear on one point. Can I use Brookshire’s VSA software to control and program the Mini Maestro 12?




1 Like

Hello, Luke.

Yes, it is possible. If you search on this forum a little bit, you will find several threads about people getting their Maestro to work with VSA. VSA has some sort of feature for sending Mini-SSC protocol commands, and the Maestros support receiving those commands. Just make sure that you use the Maestro Control Center to change the Maestro’s Serial Mode to “USB Dual Port”. Then you need to look in the Device Manager to identify which COM port is the Meastro’s Command Port, and that will be the COM number that you should tell VSA to connect to.


Thanks for the reply. I appreciate it.

Hi Folks,

STUCK! Had VSA and a Mini Maestro 24 working together well on a project about 6 months ago.

Now all attempts at getting them to cooperate are not working.

I’d love any tips you guys might have, I’ve stumped most people!

Here are the details:

Running from desktop PC Windows 7 OS (32 bit)

VSA Ultimate v5.001

Using Maestro 24 ( )

Trying to drive a HITEC HS-5085MG digital servo (reset using HFP-20 HITEC programmer, only end limits were programmed into servos)

Power supply is a stable 6 VDC (measured during tests), 2A regulated supply. Same that was working on functional VSA / Maestro combo before

…so, not working…start troubleshooting…


  • downloaded Pololu’s serial transmitter and sent 0xff to Maestro. Perfect communication.
  • opened Maestro control and checked functionality there, Perfect servo control

…still not working with VSA though…so:

-Flipped Maestro settings to “dual Port” in USB, applied settings, closed control.

  • still not working

-Checked baud rate, default for Maestro was 9600. VSA set to 9600 for both COM ports Maestro sets up (in my case COM 8 and COM9). Checked Windows device manager settings for moth ports, all lset to 9600.

  • still not working

Constants during this were:

  • Always changed the device type in VSA to “pololu servo”. After each system change both COM 8 and COM 9 were tested in VSA settings.
  • Always tested more than one channel (to verify it was not servo-dependant…no burned out servos)
  • Power supply at a stable 6 VDC

I have even repeated all the above on a Dell Precision M6400 portable workstation (running 64bit Vista, all other softwares mentioned above).

I have repeated all the above also using 115200, 38400 (was magic baud rate for VSA and lynxmotion’s SSC32).

Still not working.


Anybody see the issue?

I am attaching pics of the settings and the maestro settings file for fun.


maestro_settings.txt (4.46 KB)

…so, stupid simple solution:

DO NOT USE VSA versions earlier than V5 for this!!!

Guess what, they actually added “maestro servo” and “maestro relay” device types.

And it works.

Without having to go through any tweaks at all.

Thanks Brookshire Software!

Now, back to the robots…cheers!

1 Like

Hi, grayfxman.

I’m glad you got it working, and thanks for letting us know how you solved the problem!

- Ryan

I am having trouble with the VSA software connecting to my polulu maestro 12… It worked before and now I cant get it to work. The problem i’m having is that when I go into setting in the VSA software, the “port” column does not give me the port number 12 or 11 to select from. I went into my device manager and it says that my polulu is has been assigned 11 and 12. Please help me…I got it to work in the past but not sure why I cant get it to work now… :cry:

Hello, encirco.

What version of the VSA software are you using? Is your Maestro’s serial mode set to “USB Dual Port”? You should also make sure that the baud rates are set to appropriate and matching values.


Hi david. I have the same concern. I’ve spent like 4days trying to use my pololu with vsa. My servos work right away when i use the pololu maestro software since it has the option to activate or deactivate very easy to find at the main window. But with vsa i dont see where to set up the pololu. Should i keep the pololu-software open to link it to the vsa? I always close it before to open the vsa. Its very frustrating spent several days without being able to work with vsa ultimate version. I used the frightideas equipment and in 2 days i was controlling a show cause they provide manuals, the forum advices are very suggestive and not accurate to our particular needs. I have ask around in foros and tutorials for 4 days and i still cant move a single servo or upload any video on the vsa with video option. Please use more simpler language or images. i don’t understand computer tech terms. Thanks


You do not need to close the Maestro Control Center to use the VSA software. I responded to your thread here with details about getting the Maestro set up and working with VSA. Please try following those suggestions first. If you have problems, you can continue the discussion in your thread, since this one is about a different problem that existed in an older version of the VSA software. If you can provide more details about what you are doing and if there are specific terms or steps you are unsure how to do, I would be glad to help clarify.


2 posts were merged into an existing topic: Animatronics

Hi luck. Yes, i guess its the best match. I just swith to those components too.

The guys of pololu guided me on my start up and now im doing well, so, ill try to share my steps so others can avoid some frustrating easy actions. The problem is not pololu but the vsa cause there’s very little info in the manuals. I think that brookshire should certificate the pololu and robotshop team to manage the media cause so far its not their responsibility but they end up helping more than the people from vsa.