DRV8825 - can't change the vref

I’m building a 3D printer and just started to play with all the electronics.
I connected the DRV8825 to my Ramps 1.4 board, and tried to measure the vref so I can adjust the current limit.

I measured the vref following the the diagram from this post:

The problem is the I keep getting 12.04 [v] (this is exactly the PSU voltage, I checked) no matter how much I change the potentiometer :frowning:
I checked all my 4 drivers, and it’s the same in all of them.

What am I doing wrong?


Glancing at your drawing, I don’t see anything wrong. But presumably you are indeed doing something wrong, because I don’t even think you should have access to Vmot for this measurement (I believe it’s a potentiometer through the 3.3v output according to the schematic.)

I have a method of setting the current that I find to be the most effective and easiest. You attach your ground probe to ground. Then you set your screwdriver well in the potentiometer, and then you attach your red probe to your screw driver.

The potentiometer is metal and is hot to the same voltage as that Vref via, and by going through your screwdriver you can measure it as you turn the screwdriver. It’s especially useful because that potentiometer does not have a linear response and can cause very big voltage changes with small turns :p. And you can’t easily short things, as you can with the via.

When you’re done, double check your voltage by placing the red probe onto the potentiometer (and not through the screwdriver.)


Tomek’s suggestion is a good one. If you measure the voltage the way Tomek described, do you still get the same result? If you continue to have problems after trying it, could you post some pictures of your setup?

- Zeeshan