Zumo motors do not run

I purchased my Zumo robot for Arduino from Adafruit in September. At the time I purchased it I had several projects in the queue and was not able to look at it until recently. I cannot get the motors to run.
I am using the Arduino IDE version 1.8.10
I am using a genuine Arduino Uno with the Zumo. I also have Adafruit’s pan and tilt mechanism with a Pixie2 camera installed. My goal is to have the Zumo chase a colored ball.
I have tried the following sketches: 1 – zumomotorexample – motors do not run even though the yellow user LED is blinking
2 – zumobuzzerexample – buzzer does not buzz
3 – zumo¬_motor_test_2 - motors do not run
4 – line_¬zumo_demo - motors do not run but when I observe the camera output from the PixyMon program (with a line drawn on a piece of white paper) I can see the vector move and the output of the serial monitor displays the values being sent to the tracks. This appears normal, about 200 when the arrow is pointing straight up. The left and right track values look reasonable as I slide the paper left and right. Everything appears to be working normally the motors just do not run.
I have tried some other sketches with the same results.
I have been working with Jesse French at pixycam.com and we have ruled out a sketch problem.


Have you tried running the examples directly from our library without any modifications for the Pixy camera or servos and without the Pixy camera and servos plugged in?

- Patrick

I disconnected the Pixie2 from the Arduino Uno and unplugged the Servo connections. I downloaded the Zumo motor example from github per your instructions. The sketch compiled and uploaded normally and when I ran it the motors did not run… however when I Picked the Zumo up to move it to a different place on my desk I must have squeezed the Zumo and the Arduino Uno together and the motors began to run. It appears that the Arduino was not seated properly in the Zumo shield. I have tested it several times and the motors are working normally after I reconnected the camera and the servos. Thank you for your help.

1 Like

I am glad to hear you got your Zumo working! Thanks for letting us know what the problem was.

- Patrick