Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Zumo 32u4 usb device not recognized by windows 10

#1

Bonjour j’ai acheter un Zumo32U4 quand je le connecte a mon ordinateur (windows 10) sa me le marque peripherique usb non reconnu

quelqu’un pourrait m’aider
merci .

#2

Hello I buy a Zumo32U4 when I connect it to my computer (windows 10) its me the device brand not recognized usb

could someone help me
thank you .

#3

Hello.

It sounds like you might not have installed your Windows drivers for your Zumo. If you have not yet installed the Windows drivers, you can find instructions on how to do that in the “Installing Windows drivers” section of the 'Pololu Zumo 32U4 Robot User’s Guide". If you are still getting errors on your PC after installing the drivers, please post a screen shot of your device manager list.

-Dan

#7

Hello thank you for your answer I install the driver of my zumo but it does not work its mark always the same thing looks on the screens

#8

Hello,

It looks like you are running Windows on a MacBook Air. How does that work? Do you have Windows running in some kind of virtual machine on top of macOS? Have you tried using the Zumo from macOS instead of from Windows?

Can you try using a different USB cable (one you know is working) and USB port and see if that changes anything? Also, if you are using a USB hub, can you connect the USB cable directly to a USB port on your Mac computer? Can you post a screenshot of the “Hardware Ids” property in the “Details” tab of the USB device entry you think is the Zumo 32U4?

-Dan

#9

Non je n,utilise pas Windows en cours d’exécution dans une sorte de machine virtuelle sur macOS . j,ai installer le windows officiel sur mon macboock air , avec mon frere on a essayer sur d’autre pc mais sa ne fonctionne pas . j’ai meme essayer 3 different cable usb ca ne fonctionne pas . Mon zumo a mal fonctionner quand j’ai essayer de mettre un programme .Propri%C3%A9t%C3%A9s%20de%C2%A0_%20P%C3%A9riph%C3%A9rique%20USB%20inconnu%20(%C3%A9chec%20de%20demande%20de%20descripteur%20de%20p%C3%A9riph%C3%A9rique)%2030_05_2019%2018_54_18

#10

Hello,

We can only offer support in English; can you repost in English and translate any error messages or screen captures to English as well?

-Derrill

#11

No I do not use Windows running in some kind of virtual machine on macOS. I install the official windows on my macboock, with my brother we tried on other pc but it does not work. i even try 3 different cable usb ca does not work. My zumo went wrong when I tried to put a program.

#12

Have you tried using the Zumo from the macOS instead of from Windows as Dan asked in his last post?

Can you try your cables with a known working device to see if the cable works with it (e.g. a cell phone or mass storage device)?

You also might try reviving your Zumo 32U4 using the instructions in the “Reviving an unresponsive Zumo 32U4” section of the Zumo’s user’s guide to see if that helps.

I noticed in one of your Windows screen captures that it looks like your version of Windows has not been activated; I also see an entry for a USB device that looks like a driver is incorrect. I suggest activating Windows to be sure that it is not missing some components that is keeping the Zumo from being recognized.

-Derrill

#13

hello, I try on the computer of my fair who is a hp and who has windows, but it still does not work, me and my brother have a zumo each and he also has the same problem as me, we tried to connect a telephone on 2 computers and it works, the periferique and well recognized. we also tried to reactivate the zumo but it does not matter

#14

It is doubtful you have two separate Zumo that are at fault; it seems much more likely a driver issue on your computers.

Can you un-install your current drivers for the Zumo, unplug the Zumo, then install the drivers and plug the Zumo back in after they are installed? A common problem is connecting the Zumo before installing the drivers resulting in improper driver installation.

-Derrill