Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Win XP SP3 problem installing this hardware

Hello,

I’m attempting to connect my Pololu High-Power Simple motor controller G2 18v15 on my Windows XP SP3 box but I ran into an error (see attachment). I installed the drivers first. When I connected the device I was prompted twice with new hardware windows. The first device installed correctly. The second ran into the attached error.

Any thoughts or suggestions on how to proceed?

Thanks,

Ray Dominguez

driver_error.bmp (568.5 KB)

Hello, Ray.

We do not support Windows XP anymore (Microsoft stopped supporting it in 2014). However, I suspect you might be getting that error because the WinUSB driver is missing from your system. You can try installing the drivers for our Maestro servo controller first (which include WinUSB), and see if that fixes the problem. You can find the Maestro drivers and installation instructions in the “Installing Windows Driver and Software” section of the Maestro user’s guide.

Brandon

Hi Brandon,

Thanks for the quick reply, I appreciate the help. I installed the Maestro drivers, but still no luck. I tried to update the driver, but I got the same error as before. As a sanity check I connected the motor controller to my Win 10 box and it all worked great. So the device itself is functional.

Any other thoughts or avenues to explore/test?

Thanks,

Ray Dominguez

Unfortunately, we do not have any additional suggestions.

Brandon