Wantai nema 17+ A4988 + ramps 1.4


i am using wantai 42BYGHW609 nema 17 motors (3,7V 1,7A 1,8Degree/step) with A4988 which has rs=0,2 ohm on RAMPS 1.4 and 12V 20A Power source. I couldn’t move the motors. Motors start vibrating and the stepstick starts heating up quickly even it has even cooler on.

I am using marlin firmware on reprap prusa i3. All the stepstick jumpers are on RAMPS 1.4 and using 1/16 microstep mode. I have tried pot on stepstick to turn up or down but it does not change. Also i can set the pot max 1,6V.

I have tried setting pot 0,2V up to 1,6V which is max on stepstick.

I have tried different A4988 Pololu stepsticks.

Current firmware codes for stepper is "The axis per step per unit values are (80,80,4000,1000)."
I have tried “The axis per step per unit values are (200,200,2560,1000).” and also other different numbers for step.

Please anyone has a knowledge could help?


It sounds like you might not be using any of our products. If that is the case, we cannot troubleshoot your system since your carrier boards might not work exactly the same as ours. If you are using one of our boards, could you specify which one and post some pictures of your setup that show all of your connections?