Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

VNH5019 providing power


I’m using the VNH5019 dual motor driver to drive two motors. I have 6V plugged into the motor supply and a 9v battery supplying the arduino uno that the VNH5019 is on top of. I’m trying to use the Vdd output from the VNH5019 to supply a breadboard, but I’m not getting any voltage from the pin. When I first plug in the 9v battery to the arduino the Voltmeter reads 5V at Vdd for a second then it goes to zero. Any ideas why?


I am sorry you are having trouble getting the power you want from your system. Do you have hardware/electronics plugged into your breadboard? If so, how much current is it drawing? If you remove the VNH5019 shield from your Arduino, do you get the same behavior? VDD on the VNH5019 is just the Arduino’s 5V, and the driver shield only has a few pull-ups, so it should not be drawing much current.



The only way to get it to work is to push down on the motor shield as if squeezing it into the arduino. I also tried to run a led from some of the unused pins like A2, A3, A5, etc. A2, A4, will only work if I push the shield into the arduino. I have unplugged and replugged the shield several times to ensure connection. It seems like it’s defective.


It’s one led. I don’t know how many milliamps it’s pulling. And the led
works when I plug it into the Arduino only.



It sounds like either the board is not soldered or the solder joints are not making a good connection. If you are new to soldering or need pointers, this Adafruit guide to excellent soldering, is really helpful. If you try touching up your soldering and still have trouble, could you post pictures of your driver and setup?



I have re-soldered all the joints and even plugged the shield into another arduino uno. Same results. The connections are intermittent as described above. I just bought the shield and am testing the pins that are available to be used by things other than the motor. It’s obvious to me that this thing is defective. You should replace it or give me my money back.


As I mentioned, intermittent operation is a clear sign of a connection issue somewhere, and it would be good to figure out the source of that bad connection since until we do, we cannot be confident that a replacement board will solve the problem. While it could be a bad solder connection on one of the SMT components on the board, that is unlikely as each board goes through automated optical inspection of all its solder joints followed by full functional testing, and a bad component connection wouldn’t explain why the Arduino’s VDD isn’t making it to the board. When you are pushing down, are you pressing on any specific component? Can you push in different places and still get it to work? If not, can you tell me which component you need to press on to get it to work?

If just generally pushing on the board itself (not just a specific component) gets it to work, then that strongly points to an issue with the connection between your Arduino and the board, not a problem inherent to the board itself, and some pictures might help us identify the issue. Could you post some pictures of the shield, both installed on the Arduino and by itself?

Lastly, can you use a multimeter to perform a continuity test between the VDD through-hole on the side of the driver that does not connect to the Arduino and the header pin that connects VDD to the Arduino’s VDD? Could you also check the continuity between a ground through-hole on the board and the header pin that connects ground to the Arduino’s ground?



Yes, It’s a bad connection!!! I have tried all you suggest and more. And I have tried plugging it into a different Arduino. It’s not just the Vdd connection that is intermittent. It’s also the pins A3, 13, 11, and 5. I have re-soldered all the headers. This isn’t my first rodeo.


Hello, Dano.

I understand your frustration at the situation, but did you follow Claire’s explanation of why this is unlikely to be a board defect? In particular, all of the pins you are having problems with are straight pass-throughs from the Arduino. A3, 13, 11, and 5 are just empty holes on the driver that you can solder to for mechanical purposes if you want; the entirety of the connection is between the header and the Arduino (there’s nothing the driver can do to make these connections, and there is no possible board defect that can break them since the board isn’t involved in them at all). VDD is also a just a direct connection to the Arduino’s VDD, though the shield taps into this line for its logic voltage.

My immediate suspicion is that there’s a ground issue somewhere, though even that is unlikely give that the shield makes three separate ground connections to the Arduino, which effectively rules out any possible defect with the board itself (i.e. there is no potential for a simple explanation like “this ground trace here is bad or got cut” since multiple independent ground traces are involved).

At this point, to help you further, we really need some pictures of your board so we can see what is soldered to what and how. All we can tell at this point is there is a connection issue that is independent of the driver itself, and that is incredibly difficult to troubleshoot without being able to see what’s going on.