Use 2 DRV8834


I’m having an issue, I can’t used one stepper motor when I got the two motor drivers connected. I always have to turn one off by disconnecting the motors or the logic 5V supply. Is it normal?
I’m thinking about connecting the logic supplies of the drivers to the arduino and power each driver one after the other to make my robot advance with both motor steppers.

Thank you,

Hello, Max.

Can you post some pictures or a wiring diagram of your setup that shows all of your connections?


Here’s the picture of the prototype. You can notice that I took off the logic supply so at least one of my stepper can work. Also, you can’t see it because it took of the wires, but I put the M0 and M1 in parallele because I want the same microstep for both.

I also tried to do a schema of the breadboard.

Everything is powered by 4 1,5V AA battery non rechargeable for a total of 6V.

Thank you for posting the picture and wiring diagram. Since I cannot see where your wires go when outside the frame of the picture, I cannot tell where some of your wires are connected. Can you tell me what you are using to power the bus connected to VMOT? If it is your battery pack, can you measure the voltage with a multimeter when both DRV8834 carriers are connected? Do both DRV8834 carriers work when tested separately? You might try replacing the batteries with fresh ones; non-rechargable batteries do not typically have a very long life when used in high current applications, so the behavior you are reporting could be dead or nearly dead batteries.


I’m using the 6V from the battery to power the VMOT.
I got 5.3V.
Yeah when they are separated, they both work perfectly. When both are connected together, the motor start to make a strong and wierd noise.
I’m gonna buy some new batteries and test. However, why would it work when only one is connected and not working when both are connected even if I’m using only one throw my programme.

It works now by changing the battery. Thank you!

Thank you for letting us know that changing the batteries fixed the problem!