Unresponsive 3pi line follower

My 3pi line follower that I borrowed while I order new ones for a course on testing has become unresponsive, only showing a voltage (i.e. 5092) and a blinking red underbelly LED, plus the normal two blue landing lights. Yesterday it would do the inherited program straight after turn on & showing power, by doing a 360 degree and show its IR sensor values, & then go the line & go after pressing button B again. However, in order to re-program it, I downloaded Atmel 7 and the pololu package (Windows 10). At my first attempt to reprogram (using same program, just changing max motor speed (150 down to 100), it went unresponsive per the above, even when I did reset (no change). I spent much time thinking it was the programmer drivers (no - all reinstalled, all check out), the programmer (no, it does everything it should) doing all the debugs you can. The programmer reported no errors on its read and the voltage at last attempt was low 4850 but not below the cut-off (4350), though below the report on top of the robot (5092) which is interesting. It seems the robot is the fault, not the programmer which reports it cannot communicate, since the robot ought to at least go to a default. I checked the 6-pin connector at both ends. I think I have the annoying coincidence of a robot fault just as I go to program. New robots do not arrive for > 10 days. Any ideas on how to get the robot to re-boot?


Which ISP AVR programmer are you using? Can you post a link to its product page? Also, can you provide more details on how you verified that your AVR programmer is working?

Considering you did not get any errors while programming the 3pi and that its motors can draw a lot more power than the microcontroller, if you have not already tried, can you replace the batteries with fresh ones to see if that changes anything?

- Amanda


Thanks for help & interest

Programmer is an SKU-003531 Pololu USB AVR Programmer.

I used the User Guide Section 8 to check programmer worked correctly - very helpful.

I tried changing batteries to fresh - no luck. I think I will have to wait for new 3pi & programmers to arrive and that will quickly confirm if fault is with robot.


Can you run the Configuration Utility after trying to program your 3pi again and post a screenshot of it here? Can you describe the LED behavior on the programmer?

- Amanda


So I ran the config exec again & took some pictures & screenshots for you. The 3pi has the red blinking LED at the forward left underside (picture may show this solid, but she blinks). No build (F7) or Debug F5 changes the config exec file figures. The output file is also attached.
screenshots and pictures.xlsx (2.2 MB)
test_doe.atsln (974 Bytes)
Output file.docx (12.3 KB)

Thanks Keith

Can you post a screenshot of your Device Manager with the “Ports (COM & LPT)” and “Pololu USB Devices” entries expanded? Also, can you post screenshots of the “Device Programming” window and the “Available Tools” window in Atmel Studio? What happens when you try to read the device signature of the AVR on the 3pi? If you get an error message, can you post a screen shot of it?

- Amanda


Attached are the screenshots showing the device manager, two ATMEL expansions and a read result.

Sorry I took a while. The 11 3pi robots for the course have been ordered, so that will add more devices to see what is wrong.

Yours gratefully, KeithDebugging 3pi.pptx (253.1 KB)

Thank you for posting the additional information. From the screenshot of your the Device Programming window in Atmel Studio, it looks like the AVR programmer is able to read the 3pi’s device signature and voltage, so the 3pi is responding. However, in your first post, you mentioned that the programmer reports that it cannot communicate with the 3pi. Where did you see that error? If you can reproduce it, please post a screenshot of it here. What happens when you try programming your HEX file on to the 3pi? Can you also post a screenshot showing the result?

- Amanda