Trouble using TX/RX pins

I have several SMC’s both 1st gen and 2nd gen. I have configured them using the USB port but I want to control them with a microcontroller. However, I can’t get the board to respond. I had it plugged into a UART on my beaglebone and was writing binary commands but I was unable to receive anything back. I used a logic analyzer to confirm that the binary command was transmitted to the RX pin on the SMC. I tried both querying a variable and setting the motor speed but the SMC doesn’t respond and the TX pin stays quiet. I tried the same thing with an FTDI breakout straight to the USB of my computer with the same results.

My connections are simple TX->RX, RX->TX, GND->GND. With the beaglebone I powered the board with a 7.4 volt LiPo battery on VIN with a common ground with the board. With the FTDI breakout I’m supplying power to the board by connecting the 5v USB power to the 5v BEC.

I’m certain that there is something simple that I’m missing. Is there a common mistake that I could be making?


Have you checked that the TTL serial settings are configured appropriately for your Simple Motor Controllers? In particular, either they should be set to a fixed baud rate matching what your BeagleBone or FTDI are using, or if you are using the auto-detect baud rate mode, you should make sure you’re sending an initial 0xAA byte so the SMC can detect the baud rate (as described in the user’s guides).

If that does not help, I recommend focusing on just one type of controller at a time (original or G2). Could you post some pictures showing how you have everything connected as well as the settings files from your controller? You can save the settings file from the File menu in the control center software.


It was the autobaud! Once I put an 0xAA on the front of the commands (as described in the user’s guides) it worked as predicted. Thank you for your help.

– Les Walker