Trex Jr issues controlling 2 motors

I have the Trex Jr connected via RC. I go through the process of the “secret handshake” and the Trex Jr learns the channels. I am using a Taranis radio. I am using mix mode for a tracked vehicle. I am only getting sufficient power on motor 2. Motor 1 will sometimes run, kind of intermittently. I am using a 12v battery pack for motors and BEC. Why does motor 2 run fast and motor 1 run little if non at all? Is it a power issue or an issue during the “secret handshake?” I do not have a way to use the configuration utility. I am a newbie with this.

Can you describe in more detail what you mean when you say that “motor 1 will sometimes run, kind of intermittently”? For example, when it does run, is it able to go full speed? Does it stutter as if power is being applied and removed quickly? A video of the behavior might be helpful.

I suspect there might be a connection issue. Can you post some pictures of your setup that show all of your connections? If you swap the motors so the one that runs fine is connected to motor channel 2, does the problem follow the motor or stay with channel 2?


Here is a video:
I tried switching the motors and the same thing happens. I also tried running it without BEC and get the same result.

Thank you for the video. Could you try disconnecting your motors from the TReX Jr and using the red and green motor indicator LEDs as feedback for what the motors should be doing? Are they displaying as expected? You might also try removing the mixing mode jumper so you can use the M1 LED to see what channel 1 is doing and the M2 LED to see what channel 2 is doing.


I disconnected the motors and the LEDs work fine. Here is a video:
The motors are rated 485rpm with a stall current of 3.8A (no capacitors attached)

Thanks again for the very clear video demonstration. It looks like the TReX Jr is getting valid signals from the receiver and the motor drivers are responding as expected, so I suspect the problem might have something to do with your motors or power supply. Could you try testing the motor that was not running well by directly connecting it to a power source? Also, can you try leaving the mix mode jumper off, connecting your motors, and running M1 forward and back, then M2 forward and back to see how they respond? After that, you can try swapping the signals going to channel 1 and channel 2 and see if any problematic behavior follows the channel or the motor.


Still troubleshooting this. I have done all of that. I discovered that when I test the voltage coming from motor 2 outputs on the Trex Jr I get about 5v. Whereas on motor 1 outputs I get 12v. I think the board is damaged or something got shorted causing motor 2 output to receive less power.

Thank you for the new information. At this point, it might be easiest for us to look at the board ourselves to try to determine what might be wrong with it. Please send us an email at with your order information and a reference to this thread so we can issue you an RMA number.


Ok, it was bought from Servocity though. Can I still send it to you?


You can still email us (with whatever ServoCity order information you have), and we can work it out with you.