Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

TRex Dual Motor Driver Status Light issues



I have a project I am working on which utilizes the TRex driver and dual motors connected with a power distribution board along with a 3 cell 11.1V lipo battery. Recently I hooked everything up and for some reason the driver board does not show any status led lighting up. Has any one had this issue or is there a way to reset the driver board.

Motors attached are well with in the spec with stall current at 3.85A.



Did the TReX motor controller ever work for you? Have you checked your battery to make sure it has a charge? Can you post pictures showing how you have everything connected?




Yes the TRex motor controller worked for about 3 min with load, both motors in mixing mode and no issues were observed. After that time It was not working and has not worked since.

The battery is fully charged and I have tried different batteries of the same size to eliminate that as well.

Attached is the Picture of the set up minus the motors. The motors are installed in internal housings and are difficult to get to.


Could you tell me more about how you were using the motor controller when it worked? What changed between when the controller worked and when it stopped working? Does the blue power LED light up when you power the TReX motor controller? Do you have a USB-to-serial adapter (like this one we carry) you could use to connect your TReX to a computer? If so could you see if you can connect to the TReX Configurator utility software? The TReX Configurator utility software can be found under the “Resource” tab on the product page.



At the time I was testing the operation of the dual motors utilizing a single channel on the transmitter (toggle switch). Both motors were operating in mixing mode with out issue, forward, neutral and reverse were functioning. Then after about 3 min of operation the motors would no longer turn, nothing had been switched or changed. The blue power LED does light up when power is supplied to the controller.

I will look and see if I have a USB to serial adapter at one time I had one.


Do your motors work if you power them directly (applying power directly to the motor leads)? Also, let me know if you find a USB-to-serial adapter and can connect to the TReX configurator software.



I apologize for the delay, I have tried the motors by directly applying power to the motor leads and they work just fine. I tested the USB to Serial adapter and was unable to connect the controller to the TReX configuration software. I am still not seeing any of the signal lights illuminate.


Can you show me a picture or diagram of what your connections are when trying to connect to the TReX configuration software?