Trex dual motor controller -learning problem

I’m using this to control a remote camera head with 2 motors but cannot get it to enter learning mode and recognise input correctly.

12v power supply, bec jumper connected, analogue (right hand) position selected on rc/serial/analogue jumper.
Input for channels 1 and 2 is from analogue joytstick potentiometers. These are powered from the + and gnd pins on the input block.
I have checked with voltmeter that there is +5 volts across the potentiometer and that the central wiper (ie the input) is at 2.5v when at neutral position.
Chanel 3 not needed so input tied to channel 2
Chanel 4 and 5 enable select are tied to +5 via jumper across right most pins

On power up with both so-gnd jumper and mix jumper in place, blue power led is on and both red and green status leds flash rapidly in unison.
On removing mix jumper (as per user guide) red/green status leds go out and stay off. Blue power remains on.

The user guide suggests that rapid flashing means no valid rc signals, but I have selected analogue with the jumper.

Incidentally, if I remove the so-gnd jumper and power up normally - ie not in learning mode, I get 5 red flashes followed by a green, then repeating - confirming that no calibration has been done.

Could this be a board or microprocessor fault? Any help appreciated!!


I have been trying unsuccessfully to duplicate your issue. I am still not quite sure what is going on, but I just wanted to let you know that we are looking into it and I will get back to you about it tomorrow.

  • Grant

What happens if you disconnect everything from all the signal pins and then try to enter learning mode? Could you take videos showing the process, both with and without your joystick connected?

- Grant

OK- I will try to sort out a video in the next few days and put it on my youtube page. Thanks for your help so far

Problem solved!! I discovered that my main on/off switch was faulty and had resistance in it - so although there was 12 volts on the switch, only 5 volts appeared at the controller when I put my meter across the actual terminals. Replaced the switch and it now goes into learning mode correctly!!. Now I just have to connect to a pc via the serial interface and use the configurator program to set the deadband.

Thanks for your help

I am glad that you were able to figure out your problem and fix it. Thank you for letting me know.

  • Grant