Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Ticcmd times out soon after velocity or position command


#1

I just started using a tic825. ticgui works good, but ticcmd seems to timeout less than 1 second after issuing a velocity or position command. It indicates “Operation state: Soft error” all the time. Any ideas?


#2

Figured it out. Need to send periodic reset-command-timeout’s to keep it active.


#3

Hello.

Glad you figured out your issue and fixed it; thank you for letting us know.

By the way, you could enable the “Never sleep” option, so the Tic will never go to sleep. You can find more information about that under the “Setting reference” section of the Tic Stepper Motor Controller User’s Guide.

By the way, in case you do not already know, instead of periodically running ticcmd --reset-command-timeout, you can uncheck the “Enable command timeout” checkbox in the “Serial” box under the “Input and motor settings” tab of the Tic Control Center. You can find this information in the “Setting up USB control” section of the Tic Stepper Motor Controller User’s Guide.

- Amanda


#4

Is there a way to disable the command timeout from ticcmd for a specific device?

~ Sarah


#5

Hello, Sarah.

We recommend changing the command timeout setting using the Tic Control Center, but yes, you can use ticcmd to change the settings of the device so it is possible to disable the command timeout option using ticcmd.

- Amanda