Tic T825 stepper disable timeout USB

Hello Polulu Support team,

We are using various Pololu Tic for quite some time now. Until now mainly the 36v4. Recently we started to use the T825. However, we are having issues to disable the timeout with the T825 with firmware 1.06. Until now we were using the following Python lines according to the Pololu USB documentation to set the timeout setting to 0s:

if int.from_bytes(self.device.ctrl_transfer(0xC0, 0xA8, 0x00, 0x09, 2), ‘little’) != 0:
self.device.ctrl_transfer(0x40, 0x13, 0, 0x09, 0, None)
self.device.ctrl_transfer(0x40, 0x13, 0, 0x0A, 0, None)
log.info(f’Command timeout was deactivated’)

As far as I understand, the procedure did not change for the T825. But it doesn’t work anymore. While usb reverse engineering the bytes sent by Tic control center I have not found any commando frames containing 40:13:00:09. Did I miss something about the T825? Can you help me?
Constantly sending the ‘reset commando timeout’ 0x8c is not an option for us.

Thank you for your help in advance!


Please note that our company name is Pololu, not “Polulu”.

You are correct that the procedure did not change and your commands look okay to me. However, please note that you are just modifying the Tic’s EEPROM; to make the new setting actually take effect, you should power cycle the device or send a Reinitialize command.


First thank you for the quick response and sorry for the writing mistake!

Yes, I am aware of moddifying the EPROM. I use this commandos as part of a driver during initalization. So actually it should take effect…

Could you elaborate on what exactly you are doing after you send those “Set setting” command in order to make the new setting take effect and why you think it isn’t working?