Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Tic T500 stepper motor stuck, skipping, grinding, and rattling - how to troubleshoot?

Hello,

I just purchased two soldered Tic T500 controllers to use with my pump motors (data sheet).

I read, and re-read the Tic user manual carefully (it’s a great manual btw!). However, whatever I do to try to run the motor results in motor barely moving while generating a lot of noise, grinding, skipping, etc.

Allow me to explain what I tried so far. My pump performance sheet says that it runs at 400 RPM continuously, 600 RPM intermittent. Two-phase four wire bipolar motor is 24V, 200 steps per revolution, and has max current per phase of 1.2A (data sheet linked above).

The first thing I do in Tic Control Center is to set the current limit to 1198mA at Full step, given that current per motor phase is 1.2A. This is below Tic’s limit of 1500mA and also my DC power supply can deliver more than twice this current so again I’m following the user manual guidelines.

Tic user manuals notes that speed settings are in units per 10,000 seconds. In my case, 400RPM and 200 steps per revolution = 1,333 steps per second. 1,333 x 10,000 = 13,333,333 is what I understand my max. speed setting is and that is what I input in Tic Control Settings as motor max. speed. I leave acceleration and deceleration at default values.

When I try to run the motor by clicking Resume, and either moving the slider or setting target velocity it starts misbehaving as noted above. I also tried leaving the max. speed at the default value of 2,000,000 (200.0000 pulses / s) and also increasing it to the maximum as noted in the manual, 500,000,000, but the problem persist exactly the same.

So what I finally tried in desperation was to lover the Current limit and the only thing that can make the motor rotate smoothly is lowering the current limit all the way down to 1mA. I’m quite confused by this but after realizing this I tried playing with Max speed and Current limit settings and it seems to me that it’s only the Current limit that controls the speed and not the Max speed setting. The issue is, at 1mA I am nowhere near the speed of 400RPM on the pump, and I also assume the torque.

The whole time Tic Control Center reports VIN voltage at 23.7-23.8V so I think that is OK. Also, I have two DC benchtop power supplies, two pumps and two Tic T500 controllers, and the same thing happens with every combination of the devices so I tried to eliminate hardware issues that way.

So please can anyone suggest what would be the way forward to pair the controller and the motor so my motor will run as designed? Thank you so much in advance, any advice is appreciated!

Hello.

Just to clarify, the “max speed” setting will limit the maximum rate at which the Tic will try to spin the motor, but there are many factors that contribute to how fast a stepper motor can actually spin, including operating voltage, current limit, decay mode, microstep mode, load on the motor, and the motor itself.

When you talked about lowering the current limit, did you really mean 1mA, or was that a typo and you meant 1A?

Is the pump under any load in your test? It is not clear to me if that particular pump is directional, but if it is, you might double check that you are not trying to drive it in the wrong direction. Could you post pictures of your complete setup that show all of your connections? Also, could you post a copy of your Tic settings file? You can save a copy of your settings file from the “File” drop-down menu of the Tic Control Center while the controller is connected.

By the way, is that the complete datasheet for the stepper motor or do you have any additional information about it? In particular, it would be helpful if there was some kind of performance curves (such as a pull-out torque curve).

Brandon

Hi @BrandonM,

Thank you for replying.

One thing I didn’t mention. Manual on page 41 gives a theoretical example of maximum allowed speed setting of 500,000,000 which is then approached by first entering -4,000,000 or 4,000,000 in the Status tab. Following the same logic and ratios, I tried setting my maximum at 13,333,333 and then starting velocities as -106,666 and 106,666 and dragging the scroll bar. Next I tried -320,000 and 320,000 and so on. So I tried to ramp up/down instead of going only for the Max. speed.

I did mean 1mA (one milliamp), literally the lowest Current limit you can set. This is the most baffling part and the reason why I’m asking the question here on the forum. As soon as I started increasing the Current limit up from 1mA the motor starts acting up, at first by a little but then with each increment more and more. By the time I reach 1.19A preset the rattling and shaking becomes ridiculous. At 1mA the motor runs smoothly, albeit quite slow, say, 1 rev/s.

All my tests were done with no load on the pumps. I don’t have any loading diagrams but I tested the motors with no load whatsoever, without the hoses even. Motors are bidirectional. I will post the pics asap but for what it’s worth I followed the instructions to the letter. Black and green wires to circuit A, red and blue to B. I tried swapping black with green wires, and red with blue and nothing changes. If there was an issue with the DIR this rewiring should show it.

Just to reiterate, I have six devices in total (a pair of each power supply/motor/controller) and any combination of the devices produces the exact same issue. Power supplies I’m using are bench-tops from two different manufacturers and I used them extensively in our lab with other motors and without any odd behavior. The pumps are lab grade and dare I say pretty damn expensive, I’d be truly surprised if they are both lemons straight out of the factory… And i do believe I got good controllers, so overall I do not believe this is a hardware issue.

Thanks again.

I just wanted to provide an update on the efforts and the progress I made and share what I learned in hope it will help someone else in the future. Also to ask about another interesting thing I encountered.

First off, I made the pump work smoothly by setting not only the Input and motor settings section Max speed to my calculated value of 1333.3 pulses/s, but also the Status Set velocity limits to -1333.3 and 1333.3 pulses/s, together with Set target position also to 1333.3 pulses/s. I set the Current limit to 1189mA and Step mode to Full step. So for my motor to work I had to set everything to the same value, including the Set velocity limits. Not sure why this was an issue before but suddenly everything works. At zero load (no hoses in the pump), the current draw is about 220mA.

I still have questions regarding reduced speed behavior. I noticed that motor works somewhat “roughly” if I reduce the velocity via Set target position. For an example, if I want to reduce the velocity to 1/4 of the max. velocity, I first tried to Set target position to 1333.3 / 4 = 333.3 pulses/s. The pump will run slower but with more noise and noticeable vibration. However, if I set the target back to 1333.3 pulses/s but increase the number of pulses per revolution to 1/4 step the pump runs at the same speed but much queiter and with no vibrations. I have linked the videos and the settings files to better illustrate this. Do you have any recommendations on how to approach this requirement (lowering target velocity)?

Thank you.

Full step, max. velocity

1/4 step, max. velocity

Full step, 1/4 velocity

01. Full step, max velocity.txt (1.3 KB)

02. 1-4 step, max velocity.txt (1.3 KB)

03. Full step, 1-4 velocity.txt (1.3 KB)

Thank you for sharing your experience. There are many factors that go into how a stepper motor performs in different conditions. You might even find a resonance for your stepper motor at a certain combination of speed, current limit, and operating voltage. In general, moving slowly in full step mode is going to be noticeably rougher than higher speeds, since the slower speed means they spend more time at each position before stepping to the next one. Typically, if you want smoother motion at slower speeds, you would use higher microstepping modes. So, the behavior shown in your videos looks fairly normal to me.

Brandon