Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Tic t500 rc speed not working

Hi -

I am using the tic t500 to control a Polulu stepper motor with lead screw. I can get it to work in many modes - but not RC Speed.

To expand:
I am driving the inputs with software, and have successfully gotten the system to functions as expected with STEP and DIRECTION signals, and RC Position. but I cannot get any motion using RC Speed.

I have properly scaled the inputs using the Learn function. I have tried both with and without disabling safe start.

The software shows that it has received the command, properly scaled it, and that the motor is energized. The software shows no errors, and the leds show no errors.

But the motor does not move.

Got any ideas?

EDIT: I have solved this - but the problem seems odd to me. The default scaling factor is 200, -200. This works fine for RC Position, but must be multiplied by 1000 for RC Speed - otherwise its like a pulse every 1000 seconds.

What am I missing? If this is correct, perhaps the default targets for RC Speed should be changed.

thanks,
seth

Hello.

Please note that our company name is spelled Pololu (not “Polulu”).

I am glad you got your Tic working better by adjusting the scaling.

The meaning of the “Target” value for RC and analog scaling changes depending on if it is set up for speed control or position control, and the Tic does not store separate settings for each mode, so you will need to adjust it accordingly. The speed values are in units of pulses (microsteps) per 10,000 seconds (e.g. a speed value of 2,000,000 would result in 200 pulses per second). if you haven’t done so already, I recommend following the instructions in the “Setting up RC speed control” section of the Tic user’s guide.

Brandon

Ahhhh … I missed that. I did follow the instructions, but somehow did not pick this up. I still wonder if having the default be 200 could be improved on.

Thanks,

seth