Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Tic T500 potentiometer control

Hi All,

I’m using a Tic T500 with a potentiometer for position control of a very small stepper motor linear linear stage.

I currently have it set up with a limit switch which homes the system when power is applied. But after the homing is done, the linear stage just goes back to the original power-on position.

Is it possible to configure the T500 so that the potentiometer is setting the absolute position?

For example, what I’d really like is for the system to home after power up, and then for the stepper to move to the position dictated by the position of the potentiometer. If the analog signal is 0 volts it would stay at the home position, if it is 5 volts it would go to the maximum number of steps, if it’s 2.5 volts it goes to the halfway position, etc.

Many thanks!

Hello.

With the Tic in “Analog position” mode, with automatic homing enabled, it should do the homing procedure on power up, then go to the position being given by the analog input.

The homing procedure sets the 0 position to the homed position, and the Tic maps the neutral input 0. So you should be able to get the behavior your described by configuring your analog scaling correctly in the “Input and motor settings” tab of the Tic Control Center. To do this, you should first set your “Minimum” target position to 0 and the “Maximum” target position to your desired position at 5V. Then, you can run the input setup wizard by clicking the “Learn. . .” button. After that, you can manually re-adjust them so that the “Neutral min” value is equal to the “Minimum” value, and the “Neutral max” value is roughly the same difference as it was from “Neutral min” after running the input setup wizard.

If you try this and still have trouble, can you described what behavior your are getting that is incorrect and post a copy of your settings file? You can save your settings file by selecting the “Save settings file…” option within the “File” drop-down menu of the Tic Control Center while the Tic is connected.

Brandon

Hi Brandon,

Thanks for the quick response. I think I must have had something incorrectly configured before. I changed around the analog scaling options and now things are working great. Many thanks!

1 Like