The DIR pin does not work on the A4988 driver

I am testing the A4988 in a new configuration, yet still without motor attached. The issue I am experiencing is that I can’t set the DIR-pin high. The microcontroller (Lolin D1 mini) obliges and the pin’s voltage is 3.6V when not connected to the A4988. But it remains low when connected to the driver.
This seems to be caused by the continuity (c. 12 ohm) I measure between the DIR terminal on the driver board and both the grounds of the board. What could I be doing wrong?


Reading 12 ohms between DIR and ground seems weird. Could you post pictures of your setup that show all of your connections?


Could you post pictures of your setup that show all of your connections?

and the grand scheme of things:

Only I don’t know what good that would do, for I measure the same zero resistance when everything is disconnected. BTW, the board was functinal, a little while ago.

I wanted to see your connections in case I could catch a mistake that explains the DIR pin behavior. The connections all look good from the picture. It seems like the DIR pin is probably damaged. What happened between when the driver was working and now?


What I know what happened is this: the driver originally was connected to a Lolin32-lite board when it still worked. Too late I noticed that this board has no V-in pin and I tried to connect 5V to the battery connector. I still don’t know what went wron there, but after this, the boards USB connection wasn’t working any more. At least some pins of the board were still operational after that, but I had to replace it by another board with working serial comm and a V-in pin. Afte reconnecting the wires to the A4988 the latter’s condition is as described.

Of course, I do not know what mistakes I haven’t noticed…

I guess I’d better buy a new motor driver then.