Testing Arduino Micro


I am no longer getting blink blink as I load sketches on my Micro. The blue light and a couple of other LEDs come on, but no sign of activity beyond that.

/dev/tty.bluetooth-incoming-port <<< tried this
/dev/cu.bluetooth-incoming-port <<< tried this
/dev/tty.bluetooth-modem <<< is reported busy
/dev/cu.bluetooth-modem <<< is reported busy

I don’t see any /dev/tty.usbmodem as the instructions on Arduino site suggest should be on a Mac.

Assuming everything external to the controller is Okay, what is a good way to figure out if the controller has gone bad?

Thanks in advance.


Hello, Farzad.

In light of your subsequent post here, it looks like this is a solved issue. If you really applied 12V to something other than the VIN pin of your Arduino Micro, then it is most likely that the board is damaged beyond repair.

- Amanda

Yes, thanks. I am getting a couple of new controllers.

You know, it would be nice to have a protection similar to what we have at the gas pump where the diesel nozzle just doesn’t fit the regular tank! I almost did that to my car recently.