sy42sth38-1684a stepper motor and drv8825


I buddy of mine upgraded his 3D printer and gave me his old sy42sth38-1684a stepper motor.
I looked it up and it seems a really nice motor. I’ve also got a DRV8825 driver and tried to pair.
I’m trying to control it from an arduino.
I have followed the instructions for the DRV8825, but nothing seems to work.
The motor seems to lock (like both winding would be on) and that’s it.

Thinks I’ve tried (in combination also):

-Adjusting the current limit to 1.5A.
-Lowering the current limit to 0.4A. I can see it works as the locking torque decreased
-Modifying the supply voltage (I have a variable DC-power supply).
-Changing the stepping resolution (went from M0 high, to M1 high, to M2 high).
-Increasing the delay in the arduino sketch. (basic one: set 1 pin direction, another step. put direction high toggle a few times step pin. Change direction, repeat.). Feedback was sent to the serial monitor to make sure it’s working. I have delays between each change of the pin and went from 0.02 sec to 1 second for each delay to no extent.
-Tried stepping manually, by swinging the step pin from 5V to GND. The shaft is still locked.

I’ve made sure RESET and SLEEP are high. if I put any of them low, the outputs seem to turn off, as the shaft is not locked anymore.
Pin fault is not triggered.
I’ve measured the motor winding to make sure that I’m using the correct pair. Both of them seem to be fine.

A strange think that I’ve noticed: When I’m adjusting the potentiometer, every time I’m touching it with my multimeter (to measure the output) there seems to be a high pitch coming from the motor. I have no idea why a high frequency current would start running through the motor but as soon as I remove the probe from the potentiometer it goes away.

At this point I give up. Does anyone have any idea? I wanted to use the DRV8825 as it gives me the flexibility of using a higher voltage supply (I want to use it with a 30V DC supply) while chopping the current. At the same time it only uses 3 pins (en,dr,step).
The motor was working perfectly, and in my opinion still works. I can see it has a good holding torque. If I disconnect one of the outputs, that torque decreases… But most important, measurements won’t lie. Good resistance for each winding and open circuit between windings.
Can the DRV8825 be broken, as that is the one I don’t trust as much :)))

Thank you very much for the help.


Do you have anything attached to the motor’s shaft? Is the shaft moving at all (even just twitching) when you step it? What input voltages have you tried? 12V might be a good place to start in full-stepping mode. Are you changing direction after every step in your code? It is easier to try to move in one direction at a moderate speed first (20 steps/second in full step mode might be a good place to start). You might also try your testing with the current limit set to a little below the maximum continuous current we recommend for the driver (about 1.4A might be good). Can you post pictures here that show how you have everything connected in your system?

Generally, we recommend disconnecting the motor when setting the current limit on the driver board.