Stepper not drawing rated current

Hello all, I’m currently running a 2A 12V bipolar stepper from stepper online which I have wired to a Pololu a4988 driver. I tried to run it without load and it works perfectly. But when under load it seems it isn’t strong enough to move the load. I have tried setting the current limiter to the lowest possible limiting and it still does not seem to have the strength to move the load. It reads its drawing 0.65A on my multimeter and I believe maybe the current limiting on the driver is not letting it exert its maximum torque. I am running the motor at 12V and 2A on my psu and powering the driver through an arduino. Can i draw more current using my current driver or do I need a heavier duty one?


Can you post some pictures showing both sides of your driver as well as all of your connections?

There are several factors that will affect how much load your motor can handle (supply voltage, microstepping mode, etc.), but if your motor’s rated current draw is 2A, then our A4988 carrier, which can only handle around 1A without additional cooling (or 1.2A in the case of the black edition), is not probably not going to be appropriate. If you have not already, I recommend you test your system with the driver’s current limit to 1A (or 1.2A if you have the black edition). You can find guidance about how to do that on the product page under the “Current limiting” header. Also, please let me know what you set VREF to so I can confirm that it is okay.

- Patrick