Stepper Motor Not Working

OK, what am I doing wrong? As shown n the attached pictures I have it wired correctly. The stepper motor is your stepper (product# 1209 driver# DRV8825). The power supply is 12VDC with Vref at 475mV. Also, I have verified the PI python code is working perfectly but the motor does not turn.,

I have moved your post to the “Motor controllers/drivers and motors” section of our forum since it is more appropriate.

Your wiring is very hard to follow, and some of the wires go out of frame so I cannot tell what they are connected to. Could you try to tidy them up a little and post new pictures that show all of the connections? The red wire going to VMOT on the driver looks concerning, like it has possibly had way too much current through it at one point and fried, so you might consider replacing that wire.

Does the stepper motor energize at all when you power up the system?

By the way, this looks like the same setup that you posted about in your previous thread which was almost a month ago; has it ever worked for you? Your previous post was talking about using a higher current limit, so it sounds like you might have changed motors since then, but as I mentioned in that thread, you should not need a heat sink with the current limit you are using, and I generally recommend getting everything working first before adding something like that. If it is easy to remove, and replacing your VMOT wire did not help, can you do so and also post close-up pictures of both sides of your DRV8825 carrier board?


OK, here are some new pictures of the breadboard.

When I power up the driver the motor does not move or anything.

Yes, I have changed the motor to your motor (Pololu item #: 1209), thinking the old motor might be bad. That motor was 1.5. Amps per coil. The new motor is 1Amp per coil (per the motor spec). I have Vref set to 460mV.

I didn’t notice any obvious issues with your connections; could you post a copy of the code you are running? Does the motor energize at all when you power up the system? When it is energized it will hold its position (i.e. resist rotation).

Also, could you check the voltages at various pins on the carrier board to make sure they are as expected (i.e. 12V at VMOT, 3.3V at RST and SLEEP, 0V at ENBL)?


OK, I check all the pins you asked for>>>>
VMot > 12.5V
RST & Sleep > 3.3V
Enbl> GND

The motor does not energize and can be turned with little effort.

Here is a screenshot of the test code>>

It does seem like something might be wrong with your DRV8825 driver at this point, but as a last check, could you measure the voltage at each of the outputs pins on the driver when the system is powered up? Also, could you try moving it to a different spot in your breadboard just in case?


I do not know what I did, but when I powered everything up started to work!!! Then I ran the test code (the code I sent you) and it worked perfectly.

I welcome any comments and suggestions you might have about the code.

Thanks for great support :smiley: :smiley: :smiley: :smiley:

1 Like