Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

SMCG2 Comms issues with Arduino

Hi,
Looking for help with connecting and running a SMCG2 from an Arduino Nano.
I have run many of the example code provided but can’t get a response from the device.
I even plug the SMCG2 into my laptop to use the interface and it pops up as a generic serial port in device manager.
On start up the red LED stays on and the orange one flashes 8 times.

This was supposed to be s simple project but it’s taking me a long time.
Any suggestions?

Simon.

Hello, Simon.

I am sorry you are having trouble with your G2 Simple Motor Controller. When you say that you have tried the example code provided, are you referring to the sample code in the “Example serial code for Arduino” section of the SMC G2 user’s guide? If so, have you configured the settings on the SMC G2 as described in that section (e.g. set the fixed baud rate to 19200bps and set the serial mode to binary with CRC disabled)?

If that does not fix the problem and you are still receiving errors (e.g. the red LED is lit), can you try connecting the controller to USB and looking in the “Errors” tab of the Simple Motor Control Center G2 to see which errors are being triggered?

Also, could you post some pictures of your system that show all of your connections as well as your settings file? You can save your settings file by selecting the “Save settings file…” option within the “File” drop-down menu of the Simple Motor Control Center G2 software.

Brandon

Thanks Brandon,
Did you miss the part where I could not get the Controller to connect to my PC?

My apologies; I did not realize that’s what you meant when you said you said it shows up as a generic serial port. The name showing up as something like “USB Serial Device” can happen when you connect the controller before installing our drivers, but it should not prevent you from using the port. If you want to fix it, you can follow the instructions under the “USB troubleshooting for Windows” heading in the “Installing Windows drivers and software” section of the SMC G2 user’s guide, which reads:

If the drivers for the Simple Motor Controller’s USB serial ports are working, you should see an entry in the “Ports (COM & LPT)” category named something like “Pololu High-Power Simple Motor Controller G2 18v15 Command Port”. The serial port might be named “USB Serial Device” instead if you are using Windows 10 or later and you plugged the controller into your computer before installing our drivers for it. The generic name in the Device Manager will not prevent you from using the port, but we recommend fixing the name by right-clicking on each “USB Serial Device” entry, selecting “Update Driver Software…”, and then selecting “Search automatically for updated driver software”. Windows should find the drivers you already installed, which contain the correct name for the port.

Note that the drivers and software for the G2 version are different from the original SMC, so you should double check that you installed the correct version.

Have you tried opening the Simple Motor Control Center G2 and expanding the “Connect to:” drop-down menu to see if it is showing up?

Brandon

Thnanks,
All things I have already tried. It has made no difference.
The Pololu Motor controller device is in the USB devices.
The Serial port device is in COM ports. (right clicking and updating doesn’t change)
No Motor Controller is COM ports

I have uninstalled and reinstalled several times with no change.
Anything else?
Simon.

Could you post a screenshot showing the two entries in your Device Manager: the “USB Serial Device” and the “Pololu Motor controller device is in the USB devices”. Then, for each of those devices, can you double-click on them and tell us the “Hardware Ids”? You can find that in the “Details” tab after changing the Property to “Hardware Ids”.

Also, could you open the Simple Motor Control Center G2 software you are using, open the “About…” window from the “Help” option and post a screenshot showing the details?

Brandon

comHWID

vers
As directed.

It looks like you are using the original Simple Motor Control Center software and not the G2 version. As I noted in my previous post, they are not the same and you will need to use the correct version. You can download the Simple Motor Control Center G2 software and drivers from the “Resources” tab of any of the Simple Motor Controller G2 product pages or from the “Installing Windows drivers and software” section of the Simple Motor Controller G2 user’s guide,

Brandon