SMC G2 I2C on Raspberry Pi not showing

I have connected according to Pololu - 4.4. Connecting an I²C device

However I cannot see an address with an i2cdetect command. I have tried the alternate I2C gpio overlay and that does help either.

It is a Raspberry 4 with a 12 v power supply.

What am I doing wrong. It has to be something really simple.


Could you post some more information about what you’ve done to configure and setup the system? For example, did you enable I2C by checking the “Enable I2C” checkbox in the “Input settings” tab of the Simple Motor Control Center G2 as described in the “Connecting an I2C device” section of the Simple Motor Controller G2 user’s guide that you linked to?

If you have done that and are still having problems, could you post some pictures of your setup that show all of your connections, as well as a copy of your Simple Motor Controller G2 settings file? You can save your settings file from the “File” drop-down menu of the Simple Motor Control Center G2 software while the controller is connected.


First, if notice I am running on a Raspberry PI. There is no Control Center as far as I can tell.

As I said, I connected exactly like the photo in the reference.

You will need to configure the SMC G2 before using its I2C interface. The easiest way to do that is with the Simple Motor Control Center G2 software. Do you have a Windows PC you can use to configure it to enable I2C as I described?


If I do, what address will the I2C show?

Is it a 0d?

It is too bad you have to have a windows machine to get I2C to work. Would be better if there was a jumper.

But, thanks.

The SMC G2 “Device number” (which is user-configurable) is used for the I2C address. By default, the “Device number” on the SMC G2 is 13 (or 0x0D in hex).

It is possible to configure the SMC G2 through the command-line on Linux or macOS, but using a Windows PC with the Simple Motor Control Center G2 GUI is the easiest.