Single-stick analog mixing problem with 2x SMC 18v15


I’m trying to make a little sit-on buggy for a kid which uses the motors from 2 18v cordless drills wired up to 2 18v15 Pololu Simple High-Power Motor Controllers and controlled by a single analog joystick (Sparkfun ~10k pot). Battery is also from one of the drills, a 18v Ni-Cd.

I’ve followed the instructions in the user guide for doing the same thing with the RC channels but instead I’m using the analog potentiometer channels (as far as my very limited knowledge allows) - what i’ve got is this:

I can get each of the motors to run just fine from either of the SMCs when connected individually; mixing has been set up from input setup wizard and everything looks normal… but as soon as I connect the second controller’s signals (just the 2 analog outputs from the joystick to SMC#1 in the diagram) things go wrong:

The first SMC & motor combo still works fine -no errors and control by joystick works as before. But the newly connected controller & motor start doing strange things - at first the orange LED comes on with increasing brightness for a second or so and the motor controlled by it spins briefly before stopping… then the red error LED comes on for 3 or 4 seconds with the ‘motor stopped because required channel is invalid’ error being displayed in the control centre. It then goes off, and the motor spins again with the orange LED on, then stops with the red LED on again, and the same message displays - this keeps repeating indefinitely. In the short period when the red LED is off control of both motors via the joystick doeas appear to work.

Looking in the status tab in the control centre as this happens you can see the position of the joystick apparently moving of its own accord (even though it is not being touched), with a small signal being detected (from somewhere?) to drive the motor before the error comes on again and the cycle repeats.

I’ve tried to keep the battery & motor wires as short as possible (less than a foot from the controllers) ,routed away from the joystick wires, and they are pretty chunky and are twisted too.

Have I just wired it up wrong or is there something else obvious my novice brain doesn’t understand?!

or maybe it’s a dodgy connection on the analog signal lines? I’ve remade the splitter cable from the joystick twice as I thought this could be the problem… but still no change.

Any suggestions please?

Thanks !


I am sorry you are having trouble with your Simple Motor Controllers. I suspect you are getting the Required channel invalid error because the disconnect detection feature on SMC #1 is enabled. This feature toggles the positive (+) analog power pins and checks to make sure this toggling has an effect on the voltage on the signal pin (A1 or A2). Since you are supplying potentiometer power from SMC #2, SMC #1 should not use this feature. So, you will need to check the Ignore Pot Disconnect checkbox under the Advanced Settings tab of the Simple Motor Control Center. In addition, I recommend making a ground connection between your joystick and SMC #1.

If that does not work, can you post your SMC settings file?


Hi Jon

Thanks for your message. Unfortunatley neither checking the ignore pot disconnect box (now both analog channels on SMC #1 fluctuate wildly between 0 and -100% in the control centre and the green status LED on SMC #1 blinks continually) or making a ground connection between the joystick and SMC #1 (no change as far I can tell) has helped. [I connected the ground from the joystick to the -ve potentiometer analog pin on the SMC #1 - I take it this is correct…?]

I tried switching the cables and mixing modes around to make SMC #1 the RH controller and SMC#2 the LH - all this does is transfer the problem to SMC#2 with SMC#1 working fine.

Setting files for each controller are attached… hope you’ve got some magic up your sleeve!

smc_2_settings_LH.txt (2.98 KB)
smc_1_settings_RH.txt (2.98 KB)

I reproduced your setup and ran the settings files you attached on the SMCs; I was able to get both motors to respond like they were in mixed mode. I cannot tell if you checked the “Ignore pot disconnect” box on the correct board from your description and the latest settings files you posted; just in case there was a mix-up, can you try checking that box on both boards?

By the way, I noticed your neutral minimum and maximums were a little close together. When I tested your settings, I increased the range to about 300 units.


Briliant - that’s it working perfectly now. Checking the ignore pot disconnect box on either the LH or RH SMCs individually was not making any difference, but checking the box for both controllers has done the trick. Thanks for all you help!

and thanks for the tip on the neutral min/max too