Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Simple Motor Controller 18v7 no driver

OK, so I’m a bit late to the party. I have recently purchased 2 Simple Motor Controllers 18v7 and following the online instructions, tried to install the driver in a Windows 10 laptop.

Pololu - 3.1. Installing Windows Drivers and Software

Unfortunately the software fails and recommends manually install. Following those instructions the system say “The system cannot find the file specified”.

Simple question. Does the smc-windows-121204 install still work?

Also tried a second technique of using the Device Manager and pointing towards the device directory. A similar error “Windows found drivers for your device but encountered an error while attempting to install them”. “Pololu Simple Motor Controller 18v7”, “The system cannot find the file specified”.

I am running Windows 10 Pro - Version 1909 - Installed 19/08/2019 - OS build 18363.1379

Hello.

The latest software and drivers for the Simple Motor Controller (release 121204) should work on Windows 10. I verified that the installers in smc-windows-121204.zip works with the Simple Motor Controller 18v7 on Windows 10 here.

Which link did you use to download the software and drivers for the Simple Motor Controller? Can you post pictures showing the errors you get when trying to install the software and drivers? If you have access to another Windows 10 computer, can you try installing the software and drivers on it to see if you get the same results?

- Amanda

Error1jpg

On a clean Windows 10 laptop, the installation works perfectly.
So it’s me, not you. Apologies.
I did notice the clean laptop installs .NET 3.5 during installation.
The laptop that tries to installs with errors. has .NET 4.5, 4.6, and higher. It does not have .NET 3.5. Actually .NET 3.5 comes with Windows 10, but it is not all selected.

screenprint1

I clicked the Windows flag and ran “appwiz.cpl”
I clicked “Turn Windows features on or off” near the top left.
The top selection is ".NET Framework 3.5 (includes .NET 2.0 and 3.0) - which initially was partly selected. I expand the node and tick all the options.
Click “OK” and the additional .NET 3.5 features installed. By their name not sure they are required.
Rebooted my PC.
Click to install “Pololu Simple Motor Controller” again.
Installation works now. :slight_smile:

1 Like