Setting current limiting on my drv8825, no reading. HELP!

I just bought a DRV8825. I’d like to set the current limit with a vref value of 0.3 since my stepper motor is rated 0.6A. So i connected my 12v battery to VMOT and GND pin. I also connected my stepper motor to the proper pins.

Now I powered the battery. I put red pin from my multimeter tester on the tiny circle(also tried it on potentiometer). I put the black pin from the multimeter to the GND pin below the FAULT pin. The value I’m getting is zero. So I adjust the potentiometer by rotating it clockwise. Still at 0. I rotated it again many times, still at 0 value.

I’ve done this before because I have an existing drv8825 that I’m currently using on my motorizied camera slider that I built. I can’t use it because it’s soldered.

What am I doing it wrong?

I fixed it. I found a diagram somewhere from our forum. I connected a wire on RESET and SLEEP and connected it to my 4.8v rail. I was able to set it to 0.3 finally :slight_smile:


That sounds like the behavior we would expect if RESET and SLEEP were not connected. I am glad to hear you got it working. Thanks for letting us know.