Serious problem with my 3pi robot


First, I am french, I don’t speak very well English but I will try to explain my problem.
Recently, I bought a 3pi Robot with Atmega328p and I began to enjoy it with personnals programs.
But there are 3 days, AVR Studio crashed during I was programming in this IDE.
I don’t know if it is related but since it does not work.
The first line of my robot is systematically black (8 characters fulls) and the two is white (empty).
Last time I got it, it was because I sent a not working program to my 3pi robot (a bug from AVR Studio).
I wanted to update it but AVR Studio can’t to connect to the robot while the AVR programmer leds are greens and oranges blinking as in normal operation.
But when I try to connect with AVR Studio to my AVR programmer, its red LED lights.

I tried:

  • to remove the batteries.
  • to change the batteries.
  • to disconnect/connect the robot and the programmer.
  • to relaunch AVR Studio (with a demo program too).
  • to reboot my computer.
  • on another computer.
  • to adjust Frenquecies (2000 kHz/1.845 MHz).

But It did nothing.
I have not found any information on that.

Thanks you for your help.


What programmer were you using when AVR Studio crashed?

- Ben

What did you mean ?
Platform was AVRISP on auto port (COM4) in ISP mode ?

What device were you using to program your 3pi. Was it our AVR USB programmer? Do you know what caused AVR Studio to crash?

- Ben

I use the AVR USB Programmer given with de 3pi combo.
I don’t know why AVR Studio crashed !

Crashes during programming (almost always the result of a power loss on the 3pi robot due to low batteries) can sometimes put the microcontroller on the robot into a state from which it cannot be easily reprogrammed. It sounds like this is probably what happened to you. Given that you seem to have already tried all of the things we would recommend for reestablishing contact with the microcontroller, I think the next step would be for you to send it back to us so we can take a look at it. If you want to pursue this, please mail the unit to our address as given on our contact page, and be sure to include a reference to this thread along with the address that we should mail the unit back to. If you purchased the 3pi directly from us and you know the sales order number or the name of the person who placed the order, please include that as well.

- Ben

My robot is brand new…
I purchased this directly from you and I have the sales order number.

But I paid $ 38 fee when i purchased it + 39€ (~$ 52) for Chronopost and my robot does not work after 3 days, understand that I am a little angry.
If I will send it back to you, I hope that you will repay the shipping (All) for round trip.
What do you think about it ?

Is it not better I reprogram it myself? With your help !

PS: "If you want to pursue this, please mail the unit to our address as given on our contact page, and be sure to include a reference to this thread along with the address that we should mail the unit back to."
I did not understand everything in this sentence.

I’m sorry for the inconvenience this has caused you. We put a lot of effort into supporting our products and making sure they work when we ship them, but given the fragility of electronics products such as ours, we can only cover the cost to ship the item back to you. The microcontroller probably needs to get replaced with a new one, which is likely not something you can do yourself. If you send it back to us, we want to make sure we can identify it, so please include a printout of this forum thread and your original sales order number (or a copy of your invoice). Also, make sure you make it clear where you want us to ship it back to.

- Ben

I forgot to mention that there is one thing you can try before sending it back to us. Can you attempt to program your 3pi (i.e. make the red error light on your programmer turn on) and then use the programmer’s configuration software to get more information about the source of the programming error? Please see the configuration utility section of the programmer’s user’s guide for more information. The relevant information will be listed under the “Errors From Last Programming” section. Could you post a screenshot of the utility as it displays the error?

Can you also use the configuration utility to lower the ISP frequency to 1.5 kHz and then try to use AVR Studio to read the 3pi’s device signature (this is an option under the “Main” tab; see instruction #7 on this page of the user’s guide for more information). Don’t forget to change the programmer’s ISP frequency back to something higher, such as 200 kHz or 2000 kHz, when you’re done with the test since you can’t actually use it to program at 1.5 kHz.

- Ben

The screenshots requested:

I was hoping the microcontroller on the 3pi had been corrupted in a way that set it to run at a lower clock frequency, but apparently that’s not the problem. The error messages basically imply that the MCU is completely unresponsive to your programming attempts, which means the next thing we’d try is replacing the MCU entirely.

- Ben


I’m having the very same problems, so I’ll just join in this thread …

In my case it happened during/after changing batteries: AVRStudio could not
find my 3Pi anymore. I changed cables and tried various programmers:
STK500, AVRDragon, NoName-USB-Prommer. No effect.
I can read the voltage on the 3Pi board but nothing else.

I tried everything I could think of:

  • changing ISP frequency to every possible value (in case clock source had changed)
  • trying DebugWire (as it might eventually have been switched on)
  • trying an external clock source
  • and finally - last night - High Voltage Parallel Programming (in case SPI Enable was
    switched off or the Reset pin was disabled)

Especially the latter made me despair of life :wink:
I looked up all possible connection points for the 20 (!) necessary
connections, had to solder some wires to the 3Pi-Board because
I didn’t find any other way to connect and in the end had to hold
two tiny wires to the motor-driver pins while clicking in AVRStudio
with my third hand :wink: … at two a.m. …
Of course nothing …

So now I have said goobye to it and buried it in my deepest drawer …

Let me say something at this point:
Your robot is really nice, very promising and all but there must be a second
edition of it some time … some examples why I think so:

I one day realized that one of the blue lights was missing. After a quick search
with a magnifying glass I saw that the zener diode for making 5V out of 9V was
missing. I was able to replace it but I think that things like that shouldn’t happen
so easily. Maybe on the bottom side there shouldn’t be more components than
are actually necessary (i.e. just the LEDs but not resistors and so on).
The bottom will always be in contact with stuff, even under laboratory conditions …

Also, in my opinion there should be an easy way to connect to each and every pin
of the processor. Even if thoses connectors are distributed across the whole PCB,
no matter.

Unfortunately, the processor’s package You are using is rather unpractical for the amateur.
I think hardly one of us will be able to replace such a processor successfully. Whereas
a chip of the (onyl slightly bigger) TQFP package I could resolder with few problems.

Finally, more freely available pins for expansions would seem to be in order :slight_smile:

I will not start talking about the strange phenomenon that Your robots are
twice as expensive as soon as they’ve reached Europe :slight_smile:

To wrap my ranting up: it was great fun to have one of Your little robots while
it was alive … but before buying another one I will wait for “Mark II” …


Hi guys,

in addition to my last post (which in retrospective seems a bit negative which neither
at the time nor now was really felt …) I would like to report success:

I DID it :slight_smile:

I removed the chip by using a hot air gun. Got another chip. And resoldered it, again
by using the hot air gun (and a fine tip solder iron).

Well, although practically frying the pcb I probably didn’t really solder the mass plane
underneath but still it works. So what.

( I’d still prefer another package but I don’t insist anymore :wink: )


Thanks for the update, and congratulations on the successful operation.

- Jan