Need help for my 3pi - Unable to enter programming mode


I new in this forum. I just bought 3pi for my project. Before this I been able to use it flash it with program example provided.

However, recently suddenly my 3pi seemly been crashed. I am not sure about the problem, but it seem I am not able to access my 3pi. When I try to connect it, it will shows the message “Unable to enter programming mode. Verify interface settings, target power and connections to the target device

I have follow the instructions provide in User Guide to troubleshoot my 3pi. I have checked my programmer version and ISP connection to 3pi.

Also, when I searched at previous posted forum, I’ve found that I have similar problem with this one. (Serious problem with my 3pi robot)

So by following this guy, I also have tried to:

  • to remove the batteries.
  • to change the batteries.
  • to disconnect/connect the robot and the programmer.
  • to relaunch AVR Studio (and try to use different version).
  • to reboot my computer.
  • to adjust Frenquecies (2000 kHz/1.845 MHz).

My 3pi also not respond at all when I push any button. It just display 8 black full characters at LCD display when I powered it on.

So, I just want to ask,

  1. Is it any further actions I can take to troubleshoot my problem ?
  2. Is it the MCU is crashed and need to be replaced ? If so, how can I replaced the MCU?

For your information, I use AVR USB Programmer with firmware version 1.07.
My AVR MCU is ATmega 328p

Hope, you all can help me with this problem.

Thank You very much.


Hi, Raihaan.

I am sorry you are having trouble with your 3pi robot. Could you describe exactly what happened when the 3pi first stopped working? What was the last program you tried to load onto your 3pi? Also, did you have any additional hardware connected to your 3pi when it failed?

- Zeeshan

Tq for your quick reply.

I am not sure what had happened. Previously, I have successful loaded program example (line following) provided at Guide Sheet and run 3pi without any error.

Then, after didn’t touch my robot for a while (almost 3 months), I try to start my robot and I stuck at this problem. 2 Blue LED at the bottom lighted normally when I switch on the robot.

When I connect robot to programmer, Green LED light (SOLID) and Yellow LED flash normally.

However, when I try to read ID from robot or try to program the robot it give this error,
“Unable to enter programming mode. Verify interface settings, target power and connections to the target device”

Then, I also checked with USB AVR configuration utility program. It indicate something that I “Did not set the ISP frequency lower 1/4 than target frequency” - which I think I have set correctly.

Also, I did not have connected my robot with other external device.

Hope you can help.


When you first powered it on after 3 months, was it still appropriately running the last program you had loaded on it? At what point did it stop running that program?

- Zeeshan

No. It did not responded as before. When, I switch on it after 3 month, it did not move and not show any responded when I push any button. The display just show black bar at the first line. But, blue LED light normally.



If it was working properly before you put it away for three months, then I am not sure what went wrong. Could something have happened to the board while it was being stored? Could you post some pictures showing the top and underside of your 3pi robot?

- Zeeshan

Sorry for late reply.

Here, I attached picture showing my robot after switched on.

Thank you.

Thanks for the pictures. Unfortunately, I do not see anything obviously wrong with your 3pi. As a final effort, could you try detaching the LCD and see if that will allow you to program your 3pi? If this does not work, then the board is likely damaged. If you email us directly with your order information, then I might be able to get you a discount on a new 3pi.

- Zeeshan

Hello Zeeshan,

I have tried to detach LCD display and still not be able to access my robot. I guess the MCU must be damaged. So, I decided to buy new one because I really need it for my project.

Just for your information, previously I did not bought 3pi robot directly from Pololu company, but from local distributor in my country. Here, is the item number: #975

I just want to ask, is it any possibility to get any discount if I buy new 3pi robot to replace my robot ?

Thank You.

We can not offer you a discount through your local distributor. However, if you email us information on when and where you purchased your 3pi robot, then we might be able to offer you a discount through our website.

- Zeeshan

I faced the same problem, but luckily I can say: the robot is NOT broken.
We installed the Atmel-Studio and Drivers for USB-Programmer on 16 similar Computers in school. It was working on 3 and not on all others. Uploading code leads to the problems described above. WHen uploading on one of the 3 PCs, everything is fine again (same robot, same programmer). It seems to be a problem of Atmel Studio working with the USB-Programmer.
So our workaround/solution:
Use avrdude as described in the avr_programming_quick_start_guide and it works on all machines.
We use Atmel Studio for coding and avrdude with a nice batch-file for uploading.
So long.