Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

RPi with DRV8825 and NEMA 17 -- Debugging/Diagnostic Help

Hi all. I’m new to working with stepper motors.
I’ve been following this tutorial on a bare bones circuit. All of my hardware is the same as the tutorial except that I am using a NEMA 17 1.5A Stepper Motor.

I have set up my circuit thusly:

I have followed the tutorial up to actually making the stepper motor move. When I execute my python code, the motor does nothing. I know that voltage is reaching the driver because I am able to adjust vRef using the potentiometer. I also know that my raspberry pi signals are reaching the driver as I’ve wired LEDs into the GPIO circuits and they flash at the correct time and interval.

I’ve also used the tutorial’s method (more LEDs) to ensure that i am correctly pairing the stepper motor wires.

I tried initially with vRef set to 0.35, then 0.55 and 0.75 (which I believe is the max setting that a 1.5A rated stepper motor can handle correct?). I have also tried using two different stepper motors with no luck.

Can anyone think of what else could be the problem? My only other idea is to ensure that current is actually entering the stepper motor, but everything thus far indicates that this is the case.

Hello.

Yes; a VREF setting of 0.75V would set the current limit to 1.5A per phase.

Can you post close-up pictures showing the soldering on your DRV8825 board? What do you have your power supply set to?

You might try testing your setup separately from your code by removing your connections to the STEP and DIR pins, then manually connecting and disconnecting the STEP pin to 3.3 V repeatedly while the DIR pin is connected to ground to see if the motor steps at all? You probably want the driver operating in full step mode (e.g. the MODE# pins disconnected or driven LOW) to make it easier to see the steps.

- Amanda