RoboClaw Windows driver? [Solved]

Apologies if this isn’t the right forum. I just got a RoboClaw 2x7 and wanted to try it out on my 64-bit Windows 7 machine. I downloaded the drivers from the manufacturer’s website (and also tried from this site) but when I double-click it (USBRoboclawVirtualComport.exe) it says:

“The version of this file is not compatible with the version of Windows that you’re running. Check your computer’s system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.”

I did leave a question about this on the software publisher’s website, no word yet. I thought it was strange that nobody has mentioned this problem on this forum (that I found) so I figured I’d post here as well.

Thanks for any insights!


Can you post the links you used to download the USB Roboclaw driver for Windows, including the one you said you tried from our website? I am not familiar with that executable name for the Roboclaw. Did you mean

Which forum are you referring to? Can you post a link to your question on the other website?

- Amanda

Hi Amanda,

This is a facepalm. Basically this is a non-issue for most people and I goofed up everything. Once I was able to download the zip file from the manufacturer’s website (my corporate proxy was blocking it), there is an executable “DPinst64.exe” in the zip file that installs the 64-bit drivers, and they are now working for me. Ignore me! :wink: