RoboClaw 2x60 Blowing Fuse during Power On

I have a RoboClaw 2x60 Controller running a Pittman motor to turn the dome on an R2D2 build. This has worked perfectly before with no issues. Suddenly, the Roboclaw has started tripping its circuit breaker on power on. It will trip a 30A breaker with no load on it (outputs disconnected). I removed it and applied power from a 12V battery - the alligator clip fused to the screw. Yet when it completes powering on, all looks normal - green Stat LED - no Err. Reapplying voltage immediately seems normal - no sparking/fusing. Wait a minute and reapply - back to same problem. Any ideas on this one? Might it be the capacitors?
Thanks much!

Hi, Scott.

It does sound like the issue could be that there is too much capacitance it your system and charging all of it from nothing is causing a very large inrush current. However it is hard to be more sure without knowing more about your system. You mentioned that you tested with a 12V battery. What do you normally use to supply power to your R2D2? Have you added any capacitors to the RoboClaw? What are the voltage and current ratings of your motor? Could you be more specific about what the robot is doing when the breaker trips? Is it when you are just powering up the robot, but not moving anything, or are you trying to spin the dome right away when powering up? Also, you mentioned that it used to work; has anything in your system changed since then?


Hi Claire,
Thanks for the reply. The R2D2 normally runs on 24V (2x12V Batteries). The motor it runs is a gear reduced 12-30V Pittman motor that’s rated at 6 Amps Max. It actually spins the dome with a 9V battery, so I don’t think anything is overloaded. There are no additional capacitors.
The breaker trips as soon as power is applied to the RoboClaw board. I disconnected the motor so the only circuit was Batteries -> Breaker -> RoboClaw. No load - still pops the breaker. That’s when I removed the board and applied power on the workbench. 12V connection throws sparks and melts a spot on the alligator clip. After connection all is OK. Just pulls all that current on initial connection.
And I was mistaken earlier - it’s actually a 2X30A (vers.3). This one has the two large 1000uf capacitors. I’ve noticed it does not pull current if t is disconnected and reconnected.
The only change since it worked was I swapped the fuse panel for a breaker panel.
Thanks again!

Seeing sparks and melting plastic when you are connecting a 12V source is concerning. Did that happen with the breaker or just the RoboClaw? I recommend testing the breaker and RoboClaw separately, in order to figure out which is causing the issue.