Raspberry Pi B+ with DRV8835


I just recently got a Raspberry Pi B+ (as a birthday gift since I was playing around with my friend’s Arduino, I don’t really know much of what to do with it yet) and I came across your website thanks to a video on YouTube called Raspberry Pi Robotics #2: Zumo Robot which suggested getting a Zumo kit from your company. The motor driver suggested in that video was not one that I could find on your site, but I did see that you had suggestions for the DRV8835 and that other people had purchased it with what I had and was planning to get, so I ordered the Pololu DRV8835 Dual Motor Driver Kit for Raspberry Pi B+. After assembling everything, including soldering, which I don’t have much experience with, I went to GitHub and installed the Python library, but I still can’t get the Zumo to move with the example code.

I’ve tried simplifying things to test and I was able to successfully get the blinking light example from Raspberry Pi Robotics #1: GPIO Control to work just fine still after unplugging the DRV8835, using the breadboard and LEDs that I bought from here :wink:, but I’m guessing that I’m just doing something wrong with the DRV8835. Is there a blinking light test or something simple that I can try with the DRV8835?

I’m adding a photo of my setup here, just in case it helps. I’m using multiple jumper wires connected together to go from the Raspberry Pi to the Zumo. I didn’t get the step up/step down regulator - I’m using the micro USB for running power to the Raspberry Pi for now, but I do have 4 AA batteries in the Zumo. (I was thinking that I needed that to run power for the two motors, so those wires are connected in my interpretation of the image on the DRV8835 page.

Am I completely off in the wrong direction with my thinking?


It sounds like you are on the right track; the example code on the DRV8835 Dual Motor Driver Kit for Raspberry Pi B+ Python library GitHub page should drive each motor in both directions and is where I would recommend starting.

It is not clear from your photo how you have everything connected, but it looks like you might have your motor power applied backwards (your red wire looks like it is going to GND and the black one to VIN). Could you post a wiring diagram of your connections or a picture that shows more clearly what your connections are? What happens when you run the example code (e.g. do you get an error)?


Hi Brandon,

I didn’t get any errors when I ran the code. It would display “Motor 1 forward”, “Motor 1 reverse”, “Motor 2 forward” and “Motor 2 reverse” and then go back to the prompt.

I had to check the image from the website to verify which position was which, but you were right, I had the positive wire from the Zumo connected to the GND of the DRV8835. I’ll give that a try and see what happens. Thanks for the comment.

  • Nathaniel

It’s (partially) ALIVE!

“Motor 1 forward” - nothing.
“Motor 1 backward” - nothing.
“Motor 2 forward” - The right side started going forward!
“Motor 2 backward” - The right side moved back (running into the case of the RPi)!

After picking it up to check over the wires, I noticed one of the wires loose. The positive wire had come loose from the left motor. So… I guess I need to go back and re-solder that wire to the motor and try again.

Thanks again Brandon!

I am glad you found the problem; thank you for letting us know. Good luck with your Raspberry Pi controlled Zumo! Once you have it working, you might consider posting about it on the “Share Your Projects” section of our forum.


Hi having trouble installing wiringpi2 I get 404 when running
sudo apt-get install python-dev python-setuptools

mirrordirector.raspbian.org/raspbian/ wheezy/main libssl-dev armhf 1.0.1e-2+rvt+deb7u11 404 not found
Http … wheezy/main libssl-doc all …

Failed to fetch mirrordirector.raspbian.org/rasp … _armhf.deb 404 not found
Http…all.deb 404 not found

Without wiringpi2 the example won’t run, any help welcome

OK fixed it had to do apt-get update to fix


I am glad you figured out what the problem was! Thank you for letting us know how you solved your issue.

- Amanda