Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Qtr 8RC reading problem

Hi,

I have qtr 8rc sensor, But i couldnt read the values from it.

How can I test my sensor? I connected vcc and gnd.

each sensor outputs are connected to a led.

When i pass the white or black thing on sensors, i see nothing change in the leds.

Why?

Also I have tried doing this with ardino. Result was the same. I read values 0 0 0 00 0 00 0 0.

sensor outputs to aurdino digital pins (3-10). I used example codes.

Please help me…

Hi,

First, I just wanted to test the sensor separate from aurdino,

I connected sensor vcc and gnd, and I put a led to sensor output, when I see the camera sensors was working, I saw the light, but when I pass a white or black material on sensors, I see nothing change on the led.

Second, I tested with aurdino, I used below

github.com/pedcremo/projecteInt … xample.pde

I’ve connected 8 pins to aurdino, but I always read 0 0 0 0 0 0 0 0 0, although I pass white and black material on sensors,

Also you can check from that video, what i want to do,

aldtuning.net/videos/index.p … x_oDnX4Azw

Hello.

I am sorry you are having trouble with your QTR array. Can you remove the LEDs and try running our QTRRCRawValuesExample sketch and tell me what values you get on the Arduino serial monitor? Also, can you tell me more about your setup? How are you supplying power? Can you post pictures that show your connections?

-Jon

Thanks for reply,

You can see the picture, connections and the values.

I’ve connected vcc and gnd. Vcc is 5v.

sensor outputs to ardino digital pins(3-10).

as you can see in the picture,Values are complicated.





It looks like you are getting some fairly consistent readings for all of your sensors, but you might just be holding the board very evenly. Can you try running the QTRRCExample.ino sketch, making sure to expose each sensor to the most IR reflective and least IR reflective (e.g. white and black surfaces) surface in its environment during the 10 second calibration phase, and post a screenshot of your serial output?

-Jon

the values are 0 0 0 0 0 0 0 0.

I use white and black material during the calibration phase.

I dont know where the problem is.

I suspect that the sensors are too far away from your black and white material during the calibration phase, so the sensors are not actually being exposed to full reflectance. As we mention on that sensor’s product page, its optimal sensing distance is 0.125" (3mm).

If lowering the height of the array does not fix the issue, can you post a video that clearly shows what you are doing during the calibration phase of the example sketch? Can you also post pictures of the front and back of your QTR array?

-Jon

Hi …
I have exactly the same problem (All the readings is 0)
the senor is about 3mm from the ground and I use the example from the library
I don’t know where is exactly the problem

Hello.

I am sorry you are having trouble using the QTR-8RC. What Arduino are you using to read the data? Can you post pictures of your board (showing all connections and soldering joints) and your line following setup? Can you also try running the QTRRCRawValuesExample sketch and posting a sample of the output?

-Jon

Hi, I have qtr 8ra sensor, and one of sensor reading always output 0. Is there any way for me to get fix that issue?
.

Hello, Viraj.

I am sorry you are having trouble reading your QTR sensor. You said you have a “qtr 8ra sensor”, and we have a QTR-8RC and QTR-8A (not 8RA). Which QTR sensor do you have? Also, can you tell me more about your system? How are you supplying power? What device are you using to read the outputs?

-Jon

Jonathan, I have my polulo QTR-8RC sensor connected to the arduino with proper connections and code in order to calibrate. However when I begin my calibration by putting a white piece of paper and a black line on top of it and move it underneath the sensors, the values are only 0 0 0 0 0 0 . Please reply back as I need to calibrate my sensors to make a line following robot

I am sorry you are having trouble getting good data from your QTR sensor. Can you tell me more about your system? Which Arduino are you using? How are you supplying power to your QTR array? Can you try running QTRRCRawValuesExample.ino and post a sample of the raw values you get? Can you also post pictures that clearly show your connections and white paper with black line?

-Jon

Im having a problem where all my connections/soldering/programming is right however it still comes up all zeros. Ive tried the qtrc values examples, but it only shows 2500. PLS HELP!!!

I moved your post back to this thread since it is about the same issue. If you answer the rest of my questions and post pictures, we can continue troubleshooting.

-Jon

those were my connections , then this happened when i did my second run:

for my code i used the examples

It seems like the problem could be that the QTR sensors are too far away from the surface you are sensing, since it looks like each sensor on your board typically reads 2500, the maximum value. Also, you soldered the headers into the board on the same side as the sensors, which looks like it could be making it difficult to lower the QTR sensors close enough to be effective. The optimal sensing distance for the QTR-8RC is 3mm and the maximum recommended sensing distance is 9.5mm. If you are not already, can try obtaining your measurements with the face of the QTR sensors about 3mm from the surface of the paper you are sensing?

Also, some of the soldered joints in your pictures do not look like they are making good electrical connection, and they could be causing an issue. If you are still getting the same readings when your sensor is at an appropriate height relative to the white paper and black line, you might try touching up those joints. I recommend looking at this Adafruit guide to soldering, which should help you identify which joints are not ideal.

Finally, another thing you might check is that the Arduino pins you are connecting to match the pins you are using in the QTR example sketches.

-Jon

1 Like

My sensors are all reading zeroes again , so you are saying it must be a soldering problem right?

It could be that soldering is the issue. Have you tried touching up the joints? If so, and things are still not working, can you post pictures or a video that shows what they look like?

-Jon

2 posts were split to a new topic: Problem reading QTR-8RC