Qik 2s12v10 not moving motors

I am currently working on a robot based on the 6WD Wild Thumper chassis. For controlling the motors I am using a qik 2s12v10, powered by a 6500 mAh, 7.4V LiPo battery pack. I just wanted to make sure that the driver works and put it in the demo mode. The only result is that one of the motors is moving at a very slow speed. I think that means that the driver is not delivering enough current for the motors (which work fine when the battery is connected directly, without a driver). Could the qik be damaged? Can anyone help me solve this problem please?

Thank you in advance,

Hello, Alex.

What do the motor indicator LEDs do during your test (the 2 pairs of LEDs nearest to the power and motor connections)? Probably the easiest thing to check first is that your battery is fully charged. If charging your battery does not help, could you post some pictures that show all of your connections, as well as some close-up pictures of both sides of your Qik 2s12v10 board?


Hello, sorry for the delayed answer.
So, today I have bought a new Qik and both behave the same, so now I know that the old one is not damaged.
I have charged the battery, and also tried with a 12V 3Ah battery and the results were the same.
But the problem still remains. I have attached some pictures of the test setup, wired only for one side of the chassis.

And here you can find a link to a video of the demo running:
While this video was being filmed the wheels did not move at all.

I have also tried to increase the motor current limit but there is no difference.


Thank you for the pictures and video. It looks like red error LED is on when the controller tries to drive your motors (and is not on during the other motor channel’s operation). Since it is just running in demo mode, I suspect it is a motor fault error, which can occur when there is a short circuit on the motor output pins. Does the red LED still light up when the demo is running if you do not have any motors connected? If not, could you try connecting one of the motors directly to the motor output pins on the Qik (instead of going through the power distribution rail and using alligator clips)? Also, before you run this test, can you check with a multimeter to make sure your connections are good and there are no shorts between the motor terminals?


I did what you said (just disconnecting the wires from the power rail and connecting them again after re-twisting them) and the results are slightly better, but not nearly perfect: now, the motors on one side of the chassis work almost properly (sometimes one motor starts sooner than the other two and the other two don’t get enough current to start), and on the other side of the chassis, the motors don’t start when I put three in parallel, but start whenever I connect any two of them in parallel. I forgot to mention that all of the connections i’m talking about now are made directly, without the power distribution rail. About measuring with the multimeter, I am pretty sure that there aren’t any shorts. I have also measured the resistance of each motor, and they seem to all have around 1.4 ohm, and around 0.9 ohm three in parallel.
Do you have any suggestions?

Thank you for your reply,
I am looking forward for your reply,

Can you try the rest of the suggestions I made in my previous post? Trying each motor one at a time could show if there is a problem with one of the motors that is causing the issue. Does the red error LED (the one closer to the middle of the board) light up when you run the test?


I have finally decided to put two qik’s on the robot, which works perfectly. One of them for 4 motors and the other for the other two. This way, the robot behaves exactly as expected, so I don’t think that I will try to make it work with just one qik, even though the robot will be more expensive. I don’t know what the problem really was, I think that the qik’s short protection was kicking in because three motors in paralel have really low electrical resistance.

Thank you for your help,

Even if you held all three of those motors stalled (at 7.4 V), the current draw wouldn’t come close to the over-current or short-circuit thresholds of the driver, so I suspect the behavior you were seeing was related to a connection issue. Perhaps there was a weak short somewhere in your wiring, and you inadvertently fixed it when you changed your connections to add the second Qik.

It sounds like you might have found a solution that could work for you, but if you ever want to continue troubleshooting this further with a goal of making this work with a single Qik, please let us know.