Prusa i3 build: A4988 black edition fried, checking voltage

Hi everyone, hope this is the right forum section for my thread. And I’m a bit new to this, so please bear with my stupid questions :). I googled around for all the stuff I’m going to ask, even on these boards, but didn’t find a satisfactory answer…

So last night I finally finished building and wiring my Prusa i3 kit. I double-checked all the connections, and everything seemed fine. I first connected the Ramps 1.4 board (Arduino mega 2560+Pololu shield) to the PC with the USB cable, uploaded the firmware, everything seemed fine. I then connected the PSU to the board, again everything seemed fine (the fan on the PSU didn’t start spinning, but I guess it only does it when needed?). I then wanted to adjust the voltage on the A4988 black edition stepper drivers (had all 4 connected). First of all measuring the voltage gave nothing, 0 V. So I slowly tried to increase voltage using the trimpot and a screwdriver. Again, nothing happens, and before I have time to measure the voltage I hear a frying sound and smoke comes out of the board. I immediately unplugged the PSU and a few seconds later disconnected all components.

Everything seems to have survived except the stepper driver I was adjusting (how do I check this?). The Ramps is detected by the PC and I manage to upload things to it, so I guess it’s OK. The only time it doesn’t start up when I connect it to the PC is when I have the fried stepper driver plugged in.

I’m still not sure what happened, and I find it really hard to adjust the voltage on the stepper driver. Especially as the anchor/stop on two of the trimpots is a bit broken, so the trimpot screw can be turned freely. Does this matter? How do I check that everything survived? I have one spare stepper driver, but they’re not cheap (and neither is the ramps) so I’m a little apprehensive to try again. What could have gone wrong? I’ll gladly provide more details if needed.

Thanks in advance.


I should probably add that there is a slight burn mark around the power input of the Ramps (ground). Perhaps there was a short there? But the board still works.


I am sorry you are having trouble with your Prusa kit. I am not entirely sure what happened, but if you remove all of your stepper motor drivers from your system and test them independently, I can help you figure out if those are still working or not.

There should definitely be a nonzero voltage on the VREF pin under normal operating conditions; can you tell me how you were measuring it? Can you also tell me the current rating for the stepper motors you used in your setup?

To start troubleshooting, can you remove each driver from your setup and connect them, one at a time, as shown in the minimal wiring diagram, which is mentioned under the “Using the driver” section of the A4988’s product page? After that can you try measuring the VREF via again. If you are able to get a voltage, can you set an appropriate current limit? You could set it to the current rating of one of the stepper motors in your system or the current rating of another stepper motor you have on hand so you do not have to remove a stepper motor from your system. Can you also post pictures of each of the stepper motor driver boards?

By the way, it is possible to rotate the potentiometer all the way around, but if you turn it too far, you should be able to turn it back into a valid region and read an appropriate VREF voltage again.



I’ve tested the stepper drivers in the following fashion: I tried connecting the Arduino with the Pololu shield (i.e. Ramps) to my computer with each of the stepper drivers connected, one at a time (using different pins). The only stepper driver which causes the Ramps not to be detected by the computer, the one I suspect short-circuited and started burning. I’m not sure what happened, I first thought that I turned the voltage too high. I was measuring the VDD pin and the adjacent GDN pin with the multimeter, set to direct voltage. It seems unlikely the multimeter caused a short-circuit, perhaps the pins made contact? Anyway, as I was looking at the stepper driver that burned, I noticed that the VDD and the GND pins might have accidentally been connected when I was soldering the pins. I am including some pictures of the stepper driver in question. Thank you for the help.

Is my test sufficient to verify that the RAMPS and the stepper drivers are still working? Can I adjust the voltage of the stepper drivers with just one driver connected at a time, for safety reasons (i.e. no other components except the PSU connected). I also noticed there is a slight burn mark near one of the ground wire connections to the Ramps from the PSU (pic included). Could this also be a source for the short circuit?



We do not make the RAMPS board, so it is difficult to determine whether or not it is working, but since you can get it to work with your computer and some of the drivers, it might be okay. Also, the “slight burn mark” does not look like damage to me. (It might be dirt or residue.) Like I mentioned in my first post, I recommend testing the remaining drivers separate from the RAMPS board, using the minimal wiring diagram on the A4988’s product page.

Soldering VDD and GND together would likely damage the board when power is applied. So, if you noticed your soldering after applying power, that might be what damaged that driver. However, looking at your picture, it does not look like there is currently a solder bridge connecting power and ground. Accidentally bridging VDD and GND with a screwdriver or multimeter lead while power is applied might also damage the board, though it seems not as likely.


Thanks for the reply. So is it safe to test the stepper drivers by connecting them directly to the PSU (24V DC) according to the wiring diagram? For instance, could I use crocodile clips connected to the PSU DC cables and VDD and GND pins to adjust the voltage for each stepper driver separately? Will this voltage then be “remembered” later by the stepper driver when I connect it to the Ramps board, as long as I no longer adjust the trim potentiometer?

Yes, it is safe to connect our electronics according to the minimal wiring diagrams we supply for them. As it says on the diagram, the range of the motor power supply is 8-35V, so supplying 24V should be fine. However, the logic power supply (Vdd) has a much lower operating range (3 - 5.5V), so 24V should not be supplied to it.

The voltage on the “ref” pin is a function of Vdd, so when you set the current limit for the driver, you should use the same voltage that the RAMPS board supplies to Vdd. (I suspect it is 5V.) You can use different values of VMOT for setting the current limit and using the driver, but Vdd should be the same in both cases.

By the way, please be careful using the alligator clips; because of their size and shape it could be hard to securely clip them to only a single header pin at a time.


I decided to test the stepper drivers om the RAMPS board again, and set the correct voltage. I’m finding it difficult to measure the voltage (I’m measuring between the trimpot and the GND pin adjacent to it) accurately with the multimeter. On the one stepper driver where the stop is still there I think I get 0.4 V (which is my goal). But on the other two stepper drivers I’m testing (where the stop is broken) turning the screw on the trimpot does not seem to be doing much, as the voltage does not change… And I get different values for the voltage depending on where I measure it on the solder. I’ll try to post pics later. Could this mean those stepper drivers are broken?


I am not sure from what you have said if the drivers are broken, but it sounds like you might be measuring VREF incorrectly.

It should be possible to measure VREF by probing the top of the potentiometer with one of your multimeter probes, but if you are having trouble getting good readings, I recommend measuring it at the VREF via instead. This via is near the middle of the board close to the driver chip and can be seen circled on the bottom silkscreen of the board right beside RST and SLP. You can see more about using that via to measure VREF in the “Current limiting” section of the driver’s product page.

If you still get strange readings when measuring that via, could you take the drivers off of your RAMPS board and try measuring them when they are connected according to the minimal wiring diagram? Pictures might also help me tell if the potentiometers or boards are damaged.


Thank you for the reply, Claire. I will test the drivers more thoroughly tomorrow and take pictures. However, they do not look damaged. Are VDD and Vref the same according to the wiring diagram?

No, VDD and VREF are not the same. VDD is an input that needs to be supplied logic power so the board can work, and VREF is an output that provides a reference voltage used when setting the current limit. The two are described on the driver’s product page.

If you also post pictures that show how you were measuring those voltages, we could check to see if you were measuring them correctly.


I took a picture of the RAMPS setup with the stepper drivers and a picture of how I measure the voltage on each driver, they can be found in the link below. I measure the voltage with the positive multimeter probe on the potentiometer screw and the other on the GND pin. It is difficult to measure straight on the soldering, and it affects accuracy (the measured voltage varies depending on how I place the probe). The driver with the intact anchor/screw stop is quite easy to adjust to the right voltage, 0.4 V. But the other two drivers where the stop is missing seem to be stuck around 1.3-1.5 V no matter how much I turn the screw (using the measurement method described above). Is it possible that the screw is disconnected from the potentiometer somehow?

Also, I’m not sure I understand how to set up the minimal wiring for the drivers, using the PSU and the tools I have. Would it be easier to adjust the voltage this way?

Thanks in advance.

The way you are measuring those voltages seems fine. It is strange that you are not able to get the measured voltage to change much when rotating the potentiometer. As I mentioned earlier, it is possible to rotate the potentiometer all the way around, but if you turn it too far, you should be able to turn it back into a valid region and read an appropriate VREF voltage again. If the voltage never changes when you turn the pot to different positions around a full rotation, it seems like that driver is damaged.

Earlier you mentioned that you tried connecting the stepper drivers to your computer, one at a time using different pins. Does that mean you tried each driver in different sockets on the RAMPS board while it was plugged in to your computer? If you have not already, you should test each individual driver one at a time in the same socket to eliminate the possibility that one of the sockets is bad.

If you decide to remove the drivers from your RAMPS setup, you can use something like a solderless breadboard and these premium jumper wires to make connections with the header pins on the driver boards. Removing the drivers and testing them separately would probably not be easier, but it would eliminate the possibility of other things in your setup affecting it.


I will check tonight by moving the functioning stepper driver between sockets. Hopefully it’s only a matter of ordering new stepper drivers to replace the two that do not function. If the sockets are malfunctioning, do you think they are replaceable or do I need to buy a whole new RAMPS board? Of course, it might be difficult to assess if anything else is fried.

Unfortunately, I do not have a breadboard so I cannot test the drivers separately from the RAMPS setup.

edit So I tested the functioning (the one where I can set the voltage) stepper driver on one of the other pin slots and I can adjust the voltage fine. It therefore seems that the other two stepper drivers are broken and that it’s not the pins. I have an unsoldered stepper driver that I’m going to assemble and test, and I’ll use this to confirm my suspicions. Hopefully it’s just the two stepper drivers that need to be replaced, and not the whole RAMPS board.

It seems like those drivers were damaged when you heard a frying sound and saw smoke coming out of your setup. If you contact us and mention this forum post, we might be able to help you out with a discount on some replacement drivers.

In the future, I recommend testing your drivers separately before integrating them into your RAMPS board. The breadboards I mentioned earlier are basic tools for testing and prototyping any electronics project.

By the way, if a single socket on that RAMPS board is damaged, I don’t think it is likely that it can be replaced. You might try checking the RepRap forum for more information.


OK, so I soldered a new driver and ran some tests with it in different pin locations. I managed to get the Y motor running in Pronterface using the setup shown in the link below. I’m going to order three new stepper drivers (and a breadboard) from a local distributor and test each of them separately. Hopefully the board is fine But so far so good!

Also, I think I may have found the culprit. One of the motor wires was loose, as shown in one of the pictures in the link. Perhaps it got loose the first time I connected the board and fried the corresponding driver, along with the ones around it? Difficult to know for sure.

I have a question regarding how the driver memory functions: is the voltage setting retained even if I unplug the driver and reconnect it to different pins? For instance, could I connect it to the breadboard and set the voltage there, and later connect it to the Ramps with the voltage remaining at that value?

I am glad that motor driver is working for you.

Connecting or disconnecting a stepper motor while the driver is powered can destroy the driver. So, if that wire was loosened while your system was running, it might explain what happened.

The current limit remains the same as long as the potentiometer is not turned and the same logic voltage (VDD) is supplied.


I recently build my prusa i3. Here is instructables page.