Problems with the the control Mini Maestro 18-Channel USB Se

Hello, can you please help me to understand my problem?
2 weeks ago I purchased a Mini Maestro 18-Channel USB Servo Controller and I was incredibly happy about it :slight_smile: . I connected it to the PC via USB to play with servos to control the Servo Controller using BeagleBone Black running Linux Debian. I installed the package: libusb-1.0-0-dev and other packages … eBlack.php . I copied 99-pololu.rules in /etc/udev/rules.d/ and run the command sudo udevadm control —reload-rules . The command ./UscCmd works fine. With the command ./UscCmd —list I check the list of devices, and with ./UcsCmd —accel 0,4 —servo -0,6000 I control the servos. I do not have any issues about functions mentioned above.

My problem is the following. The Python programs refuse to run themselves and I don’t know what could be the reason for that. The code runs, but the servo is not moving. If I use the delay in the code then the green light flashes to mark the delay, but the servo is still not moving. Please, watch the attachment:


I looked at your code and did not notice anything obviously wrong. What serial mode did you set your Maestro to?

Also, I noticed that your pulse range (minTarget and maxTarget) is outside the typical range of most servos, which is between 4000 (1000 us) and 8000 (2000 us). How did you get the values for minTarget and maxTarget?

- Amanda

Yes, you are right about the “minTarget and maxTarget” . It is incorrect. this code is template which I use to control your servo. However, any code Is written by python servo not move. Even this code. I use USB without any additional configuration.

if I do the code delay, I see it on the LED. But that doesn’t matter how I change frequency or opening angle - the actuator is in place. :frowning:

I suspect that you did not configure your Maestro’s serial settings properly. By default, the Maestro’s serial mode is set to “UART, detect baud rate” mode, so the Maestro will not listen to commands from the USB virtual COM port. Please see my response to this issue which is similar to yours (except the forum member is using a Raspberry Pi instead of a BeagleBone).

- Amanda

Here is the contents of my file maestro.xml. Python code still does not work for USB :frowning:

From your screenshot, it looks like you did not see my response that I linked you to in my previous post. To listen for commands from the USB virtual COM port, you need to set the Maestro’s serial mode to “USB Dual Port” (or “USB Chained”). Again, please read my response to the thread linked in my previous post.

- Amanda

Thank you very much. You were right.