Getting Started (Yellow LED still blinking slow)

I’m using a mini maestro 12 -channel USB servo controller, but so far have not been able to drive a servo with a raspberry pi (or with my Mac).

I can see “ttyACM0” in /dev, and I’ve tried running sample code in both Python and C++ that presumably should work; I also tried the sample bash script on the resources page, but nothing works. I have 2 servos connected, both of those are verified working, and I also verified that the servos are being powered.

Noticeably though, the yellow LED has been doing the same slow blink, which indicates to me that no successful connection has been established because the baud rate isn’t set. Has anyone else experienced similar issues?


I’m still just trying to get started with the servo controller, but I can’t get anything working.

I have a USB connection and I have power to the servo controller with 2 working servos
I’m running a Raspberry Pi (also tried running things on my Mac), and I can see /dev/ttyACM0 populated
I’ve run Python and C++ sample code as well the sample bash script to send messages to the board which does nothing
Trying to read from the board results in a timeout every time
The yellow LED meant to be indicative of no baud rate set continues to blink, so I assume that has something to do with the problem.

Any help would be greatly appreciated.


We have merged your two posts since they are about the same issue.

What example code are you using? It would be nice to have links.

By default, the Maestro’s serial mode is set to “UART, detect baud rate”. In that mode, the Maestro will not listen to commands from the USB virtual COM port. You would need to set the Maestro’s serial mode to USB Dual Port if you want to send serial commands to the Maestro’s Command Port. If you have access to a Windows or Linux computer, it would be easier to change the serial mode setting on your Maestro using the Maestro Control Center. As an alternative, you can follow the steps in this post to change your Maestro’s serial mode from UART_DETECT_BAUD_RATE to USB_DUAL_PORT (not UART_FIXED_BAUD_RATE) using the UscCmd utility.

- Amanda