Problems replacing A4988 with DRV8825

I have a self made PCB board hosting a A4988 driver. It works well and smooth.

I have acquired some DRV8825 and replaced a A4988 on my board as is.

The problem is when I switch power ‘on’ the entire circuit seem to act like it is shorted. Power led flash briefly then stays off.
Interestingly if I disconnect the motor cable the problem does not happen. Power remains healthy and the led is on fine.

My motor is a basic 200 steps nema17.

The wire of the PCB with the DRV2588 is essentially the same as this diagram below.

Exception maybe is that my grounds are connected together between supply and mcu. I’ve read elsewhere this is how it is owe to be.

In an effort to understand where the issue could be I have setup a breadboard and tried various wiring combination but nothing very conclusive. Some of these wiring attempt being.

  • disconnecting the 5v from FAULT.
  • Connecting the SLEEP to 5V
  • Swapping some coil connection of the motor.
  • Disconnecting ENABLE
    After several tries I concluded my plain default connection like in the diagram above is certainly valid.

I have tried three different DRV8825 units in case it was due to a dodgy one but nope they all act the same.

Resuming with the A4988 it all run fine as it should.

Any ideas?

Problem solved I think.

I rotated the DRV8825 pot all the way clockwise. I can apply power to the entire circuit without problem now.


It sounds like you did not have the current limit set properly. Setting the current limit is required for using any of our stepper motor drivers, and aside from causing your system to not work correctly, not setting the current limit risks damaging your stepper motor and the driver. There are instructions for how to set the current limit in each stepper motor driver’s product page description under the “Current limiting” header.

- Patrick