Problem with using Jrk 21v3, unable to use Jrk 21v3 properly without configurator

Hi all, I am seeking help for a problem I face while using the Jrk 21v3.
I have connected the Jrk 21v3 with an 22.2V lithium battery, and the feedback is fetched with MPU6050 and Arduino. I have tested it with the configurator and had worked well. The motor is able to respond to my commands and travel to the target angle.
However, when I disconnect the Jrk 21v3 from my computer, I could use it for only a mere 1 minute and it would report error. I found out that it should be an “Motor driver error”. I tried to reconnect to the computer and open the Jrk Configurator once again and it worked well again.
Could anyone help figure out why my Jrk 21v3 could NOT work properly without connecting to my computer and the Jrk Configurator.
Thank you!


It is strange that this behavior seems to only happen when your system is not connected to your computer. Are you using the same 22.2V battery as a motor supply in both cases? Are you commanding the motor to do the exact same thing for exactly as long of a period of time in both cases? For the 21v3, the motor driver error occurs when there is an under-voltage, over-temperature, or over-current condition. So, it seems like since you are getting a motor driver error after some amount of time when your system is working, the jrk’s motor driver could be encountering an over-temperature condition. Can you tell me more about your system? In particular, what motor are you using? What is its stall current? How much load is on it? Can you also post pictures of your system?