Problem with motor controller 18v15

I have 2 motor controllers both having the same problem, I recently re-installed the operating system (debian) on my arm embedded device. The controllers and motors worked fine for years until I re-installed the OS. When I type lsusb I get this:

ts4200:~# lsusb
Bus 001 Device 006: ID 06c2:0045 Phidgets Inc. (formerly GLAB) PhidgetInterface Kit 8-8-8
Bus 001 Device 008: ID 1ffb:0098
Bus 001 Device 007: ID 1ffb:0098
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 005: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 011: ID 0ace:1215 ZyDAS ZD1211B 802.11g
Bus 001 Device 010: ID 0c45:62e0 Microdia MSI Starcam Racer
Bus 001 Device 009: ID 0d8c:013c C-Media Electronics, Inc.

I believe the ID’s starting with 1ffb are the motor controllers.

I have a program that sends commands to the /dev/ttyACM0 and /dev/ttyACM1, for example F1200 for move forward at speed of 1200. This has always worked before. Now it doesn’t respond.

The USB LED light is always on which seems normal, and the other LED blinks every second like it used to when it worked.

The docs don’t say to install USB_SERIAL in the kernel so I didn’t.

The only clue I have is when I open minicom to /dev/ttyACM0 at 115200 N81 no hardware control, it says it cant open it and a bunch of characters (X’s) flow tru the screen.

Can someone advise please?


** Update

This morning I connected one of the motor controllers to a windows laptop and got the motor to spin fine. So the problem is with the linux configuration, can someone tell me what drivers I need in my kernel or other options not mentioned in the manual? I need this to work under Linux again please.


** fixed

I fixed my own problem by adding the CONFIG_USB_ACM=m kernel module to my debian kernel, that was the missing part!



Great! I am glad you were able to find and fix the problem; thanks or letting us know. I am sure that others, who encounter a similar issue, will find your post most helpful.

- Amanda