Problem Driving Generic Linear Actuator with Controller

I am working with the Pololu Simple Motor Controller 18v7 (Fully Assembled) and have it connected to 12V 8.5A Power Supply (as pictured).
I have connected the controller to a 8" Generic Linear Actuator without feedback and while there are no errors listed in the Control Center,

the motor is not moving. It says it is driving but there is no movement in the motor. Are there additional settings that could allow the motor to move?




Without looking into this in too much detail yet, I can think of two immediate things that could be wrong:

  1. Are you sure the actuator isn’t already at its limit (i.e. have you tried driving it in both directions)?
  2. You are using a relatively low speed, which might not be above the minimum voltage needed to get the actuator moving. Have you tried a higher speed?

There are also a few easy things you can check to verify what’s going on:

  1. Disconnect the linear actuator, set the SMC to be driving at full-speed, and use a multimeter to look at the motor outputs. Do you get 12 V?
  2. Connect your linear actuator directly to your power supply. Does it move?

- Ben