Powering Raspberry Pi with MC33926 motor driver

The product page for the MC33926 motor driver has an example image with it powering the Raspberry Pi directly through an attached voltage regulator.

Is there any additional wiring for that, or do I just need to solder on the regulator?
Does the voltage regulator affect any of the other VOUTs on the motor board, or just the internal connection to the Pi?



We designed the board so that you can directly solder one of our 5V regulators to it through either a straight or right angle 0.100" (2.54mm) male header. So, if you use one of our regulators, or any other 5V regulator with a similar pinout, you should not need any additional wiring.

VOUT is an input to the 5V regulator, so adding a regulator should not change the VOUT voltage. Adding a regulator will just supply 5V to the pins labeled 5V on the board as well as the RPi 5V pins.

You can find more information about how to add a 5V regulator under the “Powering the Raspberry Pi from the motor driver board” section of the driver’s product page, and you can find a schematic (which you can use to see how power is handled on this board) under the Resources tab of the driver’s product page.


Got it. Thanks!

So, I finally got around to soldering the D24V22F5 voltage regulator onto the motor driver to power my Pi 3. The power supply seems to be working alright, insofar as I can ssh into the Pi and play around when it’s only connected to a battery via the driver board. But… when I try the driver’s Python test script, it crashes on


Specifically, my ssh connection breaks. Running the script worked fine before I attached the regulator.



There is a known issue with older versions of the WiringPi library that will crash your whole Raspberry Pi if your progam is not running as the root user. Can you try prefixing the command you run with sudo to make sure you are running it as root?

If that does not solve the problem, it could be your supply is not powerful enough. Have you tired testing your script with the motors disconnected?


Yep, running it as root worked fine. Thanks!