Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Power Supply Won't Start Connected To Driver

I’ve hooked up the driver and peripherals to the power supply to test and the psu will not turn on with the driver connected. When I remove the ground of the driver it starts fine so I’m fairly sure the problem is with the driver. This is the first time I’ve hooked everything up (the motor wasn’t connected), is the board doa?

PSU is an LRS-100-36, measures at 36.2v no load, so it didn’t overvolt.

Can you post more information about your setup? For example, what “driver and peripherals” are you using and how are you connecting them? Can you post pictures of your setup that show all of your connections?

Brandon


Sorry, forgot to add info. Driver board is a G2 24v13 (md31c). Other than that there’s an LM2596 converter powering an arduino mega, fan, and encoder, with a reprapdiscount full lcd and adc connected to the arduino. I haven’t connected the motor or vref resistor yet. The floating fork terminal in the photos is the ground for the driver, I also have the headers on the driver disconnected as it was getting a ground connection there. The VM and 3V3 pins on the driver are disconnected.

Edit: Should mention I tried removing the LM2596 converter and just powering the driver, no luck.

Hello.

It looks like there’s a lot going on in your system, and it is really hard to tell where all of your connections are going from the pictures. You mentioned that the VM and 3V3 pins on the driver are disconnected; did you have either of those connected to something when you tried to power the system? if so, where did you have them connected?

Also, your 36V power supply is higher than we recommend using with that G2 High-Power Motor Driver 24v13; as mentioned on the driver’s product page, under normal operating conditions, ripple voltage on the supply line can raise the maximum voltage to more than the average or intended voltage, so a safe maximum voltage is approximately 34V. Additionally, it does not look like you have installed the heavily recommended capacitor across the motor supply and ground. Please note that this capacitor is very important for good performance. More information can be found under the “Using the motor driver” section of that same product page.

If it will not start when the driver is in your system, there might be a short somewhere that is triggering some kind of protection on your supply. Could you try removing the driver from your system checking with a multimeter to see if you can find a short (e.g. between ground and VIN)?

Lastly, could you post close-up pictures of both sides of your driver?

Brandon

VM and 3V3 have never been connected, they’re unused.

I’ve adjusted the PSU down to 32.8v so that should be fine now. The capacitor is on the way, I figured it’d be fine to power up to test without the motor connected.

Between VIN and GND it’s about 4MOhms, between VM and GND its .7r, so that looks like a short to me.


Unfortunately, since you are measuring a short and there doesn’t appear to be any obvious problems with your soldering, it sounds like the board is likely damaged. It is not clear what might have caused the damage, but 36V is very close to the limit of the driver, so it’s possible a voltage spike on startup caused it. It could have also been something as simple as an inadvertent static zap. Could you email us at support@pololu.com with your order information and a reference to this post?

Brandon