Pololu USB AVR Programmer cannot program certain uC-s

I have two ATmega8 -s which I could program using your USB Programmer, but in between circuit changes (on the breadboard) I cannot program them anymore. I can’t even read the signature bytes.

Avrdude says:
avrdude: stk500v2_command(): unknown status 0xc9
avrdude: stk500v2_program_enable(): cannot get connection status
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

and AVRStudio:
Entering programming mode… FAILED
* popup message about ISP programming failing *
Exiting programming mode… OK

The m8 -s can be programmed without hassle on a STK500 and your programmer works perfectly with a m32. Together, however…

I have disconnected all the parts from the microcontrollers and tried to program them -> nothing
I tried programming them without the crystal oscillator -> nothing
I changed the ISP frequency -> nothing
I changed the voltage detection limits using the Pololu configurator -> nothing
I tried rebooting the computer(s), the programmer, redid the uCs’ connections -> nothing
I checked all the wiring and everything proved to be ok
the fuses don’t seem to be wrong

I haven’t tried changing the Hardware and Software versions inside the configuration utility and it’s quite cumbersome to get access to a Windows computer and do it. What are some valid combination to try for when I’ll have access?

What other things can I try?


Edit: the problem is very similar with USB ISP problem , but I can’t read anything from the uC

Hello, more. I’m sorry that you are having trouble using the programmer.

If you have Linux, you should download the Pololu USB SDK so you can compile and run PgmCmd. If I recall correctly, this has all the features of the Pololu USB AVR Programmer Configuration Utility for Windows. You should be able to use it to get a specific error message. Are you getting the same error message as the person in the post you referred to?

You were previously able to program the ATmega8s with our programmer, but then they stopped working, so I’m wondering what changed. Do you have an ATmega8 that currently works with our programmer? If so, it would be great if you could read the values of its fuse bytes, and also read the values of the fuse bytes for an ATmega8 that doesn’t work with our programmer, and see if there are any differences. Ideally, you would test both of these chips on the same breadboard, using the same circuit, in order verify that only one of them works with our programmer.

I doubt that changing the hardward and software numbers will have much effect. The only way they could have an affect is if avrdude or AVR Studio reads them and behaves differently depending on their values.