USB ISP problem

I tried to flash an Atmega8 on a besc and the besc no longer worked. I tried again, avrstudio4 crashed and now it seems that I am locked out.

The usb isp progrmammer flashes yellow, until I try to write anything to the chip (it will read somethings).

When I try to write, the red light comes on (solid) and the yellow light is flashing. a message in avrstudio 4 states ISP mode error and suggests lowering the speed, which I have tried every setting

Any thoughts? The fuses can’t be read, but the clock is defaulting to external oss at 16k???

Are you using our Pololu USB AVR Programmer or some other programmer, like the older Orangutan USB Programmer?

If you are using our Pololu USB AVR Programmer, you should run the configuration utility (which you downloaded when you got the drivers) and tell us what error it is trying to report with the red LED. Please attempt to program your ATmega8, check that the red LED is on, run the utility, and tell us what the error is.

In your message, what does BESC stand for? Could you provide more information about this BESC?

If AVR Studio is telling you that the fuses can’t be read, then the fuse settings displayed by AVR Studio will not reflect what’s on the AVR, so they are probably meaningless.


Using the polulu usb programmer that I bought recently along with some baby o boards

BESC = brushless electronic speed controller

Here is the message from the config utility.

The SPI command for entering programming mode was sent, but the expected response from the target was not received. Make sure that the ISP frequency setting is less than 1/4th of the target’s clock frequency.

red led is on solid and yellow is flashing and I’v tried every fequency possible

Could you try programming one of the Baby Orangutans, or at least just reading its device signature? That would tell us whether the programmer still works.

Also, what exactly happened the first time you tried to program the BESC? Did AVR Studio give any indication of an error?

When you tried to program the BESC again, what was the last button you clicked before AVR Studio crashed?


It will even read SOME stuff from the atmega8 chip, and the programmer does work with other boards.

I hit the program key, it started then a while later, it crashed

You originally said that you were “locked out”. I interpreted this to mean that you couldn’t talk to the ATmega8 at all. If the programmer can read some stuff from the ATmega8 but can’t program it, that’s pretty unusual.

What information are you able to read from the ATmega8? Can you read it reliably every time, or just sometimes?


The programmer works fine with other devices, just wondering what the error messages mean? Is this chip fried or am I locked out?

Here’s what the “The SPI command for entering programming mode was sent, but the expected response from the target was not received.” error message means:

  1. You tried to enter programming mode.
  2. The voltage on the target’s VDD line was within the limits configured on the programmer (which is good).
  3. The programmer attempted to reset your AVR by driving the RESET line low.
  4. The programmer tried to enter programming mode by sending the Programming Enable (0xAC, 0x53, 0x00, 0x00) command on MOSI and SCK, but the programmer did not detect the expected response from your AVR on the MISO line. The programmer retried this command several times but it failed each time.

I can’t say whether you are locked out of the chip (e.g. by an invalid fuse setting that tries to use a non-existent external oscillator) or whether the chip is fried just from the error message. You said you were able to read some information from the chip so I would think that it’s not fried and you’re not locked out.

You could check your connections from the programmer to the chip using a multimeter and make sure all 6 of them are connected to the right pins, especially RESET, MOSI, MISO, and SCK.


All the wiring is correct. I wired an identical esc in exactly the same way and I have no problems with it.

I think that I need a highvoltage parallel programmer to try and save this one.

Is this something that Polulu might sell? I’m not into bulding one from scratch at the moment


There is nothing wrong with the polulu usb isp programmer, just ned to take the paddles to this chip

No, sorry, we don’t sell a high-voltage programmer. If you want to do high-voltage programming, just be careful not to damage other components on the board with voltages that they can’t tolerate.


Thanks for the help… :smiley: