Pololu Dual VNH5019 m2 fault

I’ve just received my shiny new motor driver but can’t get it to drive both motors.

Tried the action referenced in vleud101’s post with the same issue.

If I run this:

[code]void setup()
{
pinMode(6, INPUT_PULLUP);
pinMode(12, INPUT_PULLUP);
Serial.begin(115200);
delay(1000);

if (!digitalRead(6))
Serial.println(“M1 fault”);
if (!digitalRead(12))
Serial.println(“M2 fault”);
Serial.println(“done”);
}

void loop()
{}[/code]

With no Pololu Dual VNH5019 attached to an Arduino Mega I get “done”
If I attach a Pololu Dual VNH5019 to the Mega I get “M2 fault” then “done”
If I comment out the stopIfFault() calls in the demo program with the power and ground connected (to a 12v 35ah lead acid battery with a charge of 12.99v) the leds showed the board cycling thru the four leds two or three times then only the M1 leds would cycle. Let the device rest for approx. half an hour tried again, this time no M1 leds at all.
Tried same process with a Duemillanova AT328 and get identical results.
Checked solder joints under high power magnifying glass, no apparent issues.
Rerun the above test program on the Duemillanova with no Pololu Dual VNH5019 board and get “done”

I’ve attached a photo of the back of the board as there is a slight flaw under the chip that drives M2. It’s not easy to see but is between the areas that appear to be where the power would be transmitted.

Running Ubuntu 12.04, Arduino 1.0.5

Any suggestions would be greatly appreciated

theFabFor here (original poster)

After a few more hours of tinkering, I discovered that the problem was that the pins mating the motor driver board up to the Arduino weren’t making solid connections.

Repeated cleaning and seating/re-seating of the board seems to have fixed the problem.

Still having issues once a Robogaia encoder board is added to the mix. Might be a similar issue.

Hello.

Thanks for letting me know how you solved your problem. It sounds like the VNH5019 shield is working on its own, so you might check to make sure that there aren’t any conflicting pins between the two shields.

-Jon